none
Erro Entity - Não foi possível carregar o recurso de metadados especificado. RRS feed

  • Pergunta

  • Estou utilizando o Entity, porém está atribuindo o seguinte erro: Não foi possível carregar o recurso de metadados especificado.

    protected void ImBtSlavar_Click(object sender, ImageClickEventArgs e)
            {
                try
                {
                    SSGModelC ctx = new SSGModelC();
                    servicos serv = new servicos();
                    serv.Cod = 1;
                    serv.Servico = TxbServico.ToString();
                    serv.Valor = Convert.ToDecimal(TxbValor.Text);
                    ctx.servicos.Add(serv);
                    ctx.SaveChanges();
                }
                catch (Exception ex)
                {
                    throw ex;
                }

    quinta-feira, 28 de fevereiro de 2013 18:46

Todas as Respostas

  • Olá Code-V8,

    Vc esta mapeando uma base de dados que já existe? ou esta criando uma nova?

    Se vc estiver mapeando uma base de dados que já existe, então verifique se o seu mapeamento esta correto.

    []s!


    MSc. Fernando Henrique Inocêncio Borba Ferreira
    Microsoft MVP - Visual C#
    while(alive){ this.WriteCode(); }
    Blog: http://ferhenriquef.com/
    Twitter: @ferhenrique
    Entity Framework - Brasil: https://www.facebook.com/EntityFrameworkBrasil

    quinta-feira, 28 de fevereiro de 2013 19:38
    Moderador
  • Fernando, obrigado pela resposta

    Estou acessando uma base já criada e conferi o mapeamento e está ok. Tem mais alguma ideia?

    Obrigado pela ajuda.

    quinta-feira, 28 de fevereiro de 2013 20:41
  • Olá,

    Vc esta usando o EF Code First? Já pensou em usar o Entity Framework Power Tools Beta 3 para mapear suas tabelas?

    Geralmente esse erro esta atrelado a algum erro no mapeamento.

    []s!


    MSc. Fernando Henrique Inocêncio Borba Ferreira
    Microsoft MVP - Visual C#
    while(alive){ this.WriteCode(); }
    Blog: http://ferhenriquef.com/
    Twitter: @ferhenrique
    Entity Framework - Brasil: https://www.facebook.com/EntityFrameworkBrasil

    quinta-feira, 28 de fevereiro de 2013 21:15
    Moderador
  • Bom dia amigo, tudo bem?

    Não sei se ainda precisa, mas acabei de passar pela mesma situação.

    No meu caso eu estou utilizando o EDMX em um projeto separado da minha aplicação web. Quando eu instanciava o contexto ele já dava zica logo no construtor da herança do "ObjectContext".

    A solução foi tranquila. Eu simplesmente copiei a connectionString de dentro da App.config e colei dentro da web config. Respeitando a ordem dos nós. Problema resolvido.

    No meu caso eu até tinha uma connectionString com o mesmo nome, mas a formatação dela estava diferente.

    Espero ter ajudado, caso ainda precise.

    Abração e tudo de bom.


    Leandro Amorim Microsoft Certified Professional

    • Sugerido como Resposta Bahia quarta-feira, 19 de fevereiro de 2014 13:27
    quarta-feira, 15 de maio de 2013 13:07
  • se ajudar alguém no meu caso deletei e refiz o model entity.
    sexta-feira, 31 de outubro de 2014 02:00
  • Leandro,

    Obrigado pela dica; Meu problema era exatamente igual ao seu. 

    As connections strings estavam diferentes em cada um dos projetos. É engraçado que a aplicação até carrega, porém esse erro sempre subia. 

    5 anos depois sua dica foi útil.

    Tanks,

    Thomaz

    quinta-feira, 16 de fevereiro de 2017 20:41
  • Thomaz,

    Lembrando que a connection string deve estar sempre no Web config e não na camada de acesso a fonte de dados.


    Diego Almeida Barreto</strong> <br/> <em>System Analyst / Software Developer</em> <br/> <img </p> </div>

    quinta-feira, 16 de fevereiro de 2017 21:20