none
NotSupoertedException RRS feed

  • Pergunta

  • Olá pessoal

    Estou tentando rodar minha aplicação feita em C# com Visual Studio2005 em um celular MotoQ11 e está me dando este erro "NotSupoertedException" na hora que tento compilar para o aparelho e nos aparelhos HTC roda direitinho, os dois modelos possuem windows mobile 6.1. 
    O que será que está acontecendo ? alguém já passou por isso ? será que o fato de um ser Touch Screen e o outro não tem alguma coisa diferente pra configurar ?

    Obrigado
    Ananias
    sexta-feira, 29 de janeiro de 2010 14:47

Respostas

Todas as Respostas

  • Olá pessoal.

    Tenho uma aplicação feita em C# e Visual Studio que roda em windows mobile, sempre rodou direitinho, mas sempre no HTC, agora quando vou instalar em um MotoQ11 me dá um erro de Execão não suportada. Estou compilando diretamente pro equipamento.
    Alguém já passou por isso ? alguém sabe o que pode ser ?

    Obrigado
    Ananias
    sexta-feira, 29 de janeiro de 2010 01:16
  • Olá pessoal.

    Tenho uma aplicação feita em C# e Visual Studio que roda em windows mobile, sempre rodou direitinho, mas sempre no HTC, agora quando vou instalar em um MotoQ11 me dá um erro de Execão não suportada. Estou compilando diretamente pro equipamento.
    Alguém já passou por isso ? alguém sabe o que pode ser ?

    Obrigado
    Ananias

    Ah esqueci de dizer que dá uma mensagem no equipametno quando a compilação está em processo que o edidor do exe não é válido.
    sexta-feira, 29 de janeiro de 2010 01:35
  • Olá pessoal, fiz uma pergunta mas ela nem apareceu aqui, então vai de novo ...

    Minha aplicão sempre rodou direitinho em HTC, mas agora eu preciso instalá-lo em um Moto Q11, mas quando tento compilar mando direto pra aplicação ele diz que o editor não é reconhecido e depois dá um erro "exceção não suportata" algo assim. alguém sabe o que pode estar acontecendo ?

    estou usando C#, Visual Studio 2008, se precisarem de mais informações é só pedir
    sexta-feira, 29 de janeiro de 2010 02:05
  • Olá Ananias,

    O primeiro passo é garantir que esse aparelho tem, pelo menos, o .NET Compact Framework 2.0 instalado... De preferência, instale a versão mais atual (3.5) para garantir:

    .NET Compact Framework 3.5 Redistributable
    http://www.microsoft.com/downloads/details.aspx?familyid=E3821449-3C6B-42F1-9FD9-0041345B3385

    --

    De qualquer forma, você tem certeza que essa aplicação foi desenvolvida para SmartPhone e não para Pocket PC?
    Os outros HTCs são SmartPhones também, certo?

    Abraços,
    Caio Proiete

    PS: Por favor, envie as perguntas relacionadas com Mobilidade para o fórum apropriado!


    Abraços,
    Caio Proiete



    Caio Proiete
    Microsoft MVP, MCT, MCPD, MCTS, MCSD
    http://www.caioproiete.com
    sábado, 30 de janeiro de 2010 20:59