none
Relacionamento entre entidades está cinza RRS feed

  • Pergunta

  • Boa noite a todos,

    Eu fiz duas entidades, a FAMILIA e a TREINAMENTO, bom deixei a entidade FAMILIA como sem exibição e criei um relacionamento entre elas do tipo 1:N Referencial.
    Bom até ai tudo bem, criei um atributo na entidade FAMILIA do tipo pick list e adicinei 3 itens.
    Coloquei esse atributo no formulário da entidade TREINAMENTO porém ela aparece cinza, desabilitado, eu não consigo entender, aparentemente está tudo certo.

    Abração galera, desde já muito obrigado.
    segunda-feira, 27 de julho de 2009 21:40

Respostas

  • Olá João,

    Você precisa dar permissão de [Leitura] na entidade [Família de Produto].

    Siga os seguintes passos:

    - Entre no CRM em Configurações -> Administração -> Direitos de Acesso;
    - Na lista de funções, abra o registro da função a qual o [usuário] que vc está testando pertence;
    - Por exemplo, abra a função [Agendador];
    - Clique na Aba [Entidades Personalizadas];
    - e finalmente dê as devidas permissões (por exemplo, de leitura) para a entidade [Família de Produto].

    []
    Gilberto Tezini - MCP ASP.NET (C#/VB.NET) / MCP CRM - (http://gtezini.blogspot.com)
    • Marcado como Resposta João Marson terça-feira, 28 de julho de 2009 18:15
    terça-feira, 28 de julho de 2009 18:06

Todas as Respostas

  • Olá João,

    Vc está dizendo que na Entidade [Treinamento] o Picklist está desabilitado? Este Picklist está realmente preenchido e a entidade está [Publicada]?

    []
    Gilberto Tezini - MCP ASP.NET (C#/VB.NET) / MCP CRM - (http://gtezini.blogspot.com)
    terça-feira, 28 de julho de 2009 12:44
  • Olá Gilberto,

    Acabo de fazer o teste novamente, eu criei a entidade familia de produto e coloquei um pick list (crei 3 opções no pick list).
    Fui na entidade treinamento, criei um relacionamento N:1 e adicionei o campo Familia de produto no formulário de treinamento.

    E incrivel, mesmo assim ela aparece cinza (desabilitada).
    Já fiz isso no passado e mesmo assim não funciona.

    Não consigo entender, o que você imagina Gilberto?


    Obrigado pela força Gilberto.
    terça-feira, 28 de julho de 2009 17:19
  • Olá João,

    Você precisa dar permissão de [Leitura] na entidade [Família de Produto].

    Siga os seguintes passos:

    - Entre no CRM em Configurações -> Administração -> Direitos de Acesso;
    - Na lista de funções, abra o registro da função a qual o [usuário] que vc está testando pertence;
    - Por exemplo, abra a função [Agendador];
    - Clique na Aba [Entidades Personalizadas];
    - e finalmente dê as devidas permissões (por exemplo, de leitura) para a entidade [Família de Produto].

    []
    Gilberto Tezini - MCP ASP.NET (C#/VB.NET) / MCP CRM - (http://gtezini.blogspot.com)
    • Marcado como Resposta João Marson terça-feira, 28 de julho de 2009 18:15
    terça-feira, 28 de julho de 2009 18:06
  • Poxaaaaa Gilberto,

    Fui lá na infra agora e foi isso mesmo.
    Toda vez que crio uma nova entidade ele tem que liberar para mim. Por acaso não tem como ele deixar eu liberado para todas as novas automaticamente?


    Muito obrigado Gilberto!!
    terça-feira, 28 de julho de 2009 18:15
  • Não, por questões de segurança!...

    []
    Gilberto Tezini - MCP ASP.NET (C#/VB.NET) / MCP CRM - (http://gtezini.blogspot.com)
    terça-feira, 28 de julho de 2009 18:22