none
Web Config 34 messages RRS feed

  • Pergunta

  • o web config da minha aplicação apareceu com 34 messages,  entre elas: "Could not find schema information for the attribute 'loginUrl'." 

                                                                                                                "Could not find schema information for the element 'http://schemas.microsoft.com/.NetConfiguration/v2.0:add'." 

    Por onde começar?

    terça-feira, 12 de junho de 2012 14:48

Respostas

  • Wilson

    ai vai um dica, pode ser que funcione

    Altere a versão do do Seu Framework,  clique com o botão direito em cima do projeto web, escolha a ultima opção "Properties".

    na Aba "Application" altere o campo "Target Framework" para ".NET Framework 3.5" .

    feito isso salve e compila o projeto novamente, pelo que vi no seu Web.Config, pode ser que funcione se vc fizer essa alteração.

    Boa sorte ai amigão!


    Herbert Agles
    Se a resposta contribuiu com a sua necessidade, não se esqueça de marcá-la, assim você beneficiará outros usuários. Sua dúvida também pode ser as de outros!

    • Marcado como Resposta Wilson Boris terça-feira, 12 de junho de 2012 17:49
    terça-feira, 12 de junho de 2012 17:24

Todas as Respostas

  • Wilson, teria como copiar aqui o conteúdo do seu web.config ? 

    Olavo Oliveira Neto
    http://olavooneto.wordpress.com
    Twitter @Olavooneto
    Facebook Olavo Neto
    Linkedin Olavo Neto
    Se for útil marque como resposta e faça um Developer feliz :)

    terça-feira, 12 de junho de 2012 15:25
  • sem dúvida, abaixo:

    <?xml version="1.0"?>
    <!--
      For more information on how to configure your ASP.NET application, please visit
      http://go.microsoft.com/fwlink/?LinkId=169433
      -->
    <configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">
      <configSections/>
      <connectionStrings>
        <add name="BRA_SIA.My.MySettings.SIAConecte" connectionString="Provider=Microsoft.Jet.OLEDB.4.0;Data Source=|DataDirectory|\SIA.mdb" providerName="System.Data.OleDb"/>
      </connectionStrings>
      <system.web>
        <customErrors mode="Off"/>
        <roleManager enabled="true"/>
        <globalization culture="pt-BR"/>
        <authentication mode="Forms">
          <forms name="ckLog" loginUrl="SIAlogin.aspx" defaultUrl="PRINCIPALequi.aspx" timeout="30" path="/"/>
        </authentication>
        <compilation debug="true" strict="false" explicit="true" targetFramework="4.0">
          <assemblies>
            <add assembly="System.Web.Extensions.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
            <add assembly="System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
            <add assembly="System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
          </assemblies>
        </compilation>
      </system.web>
    </configuration>


    • Editado Wilson Boris terça-feira, 12 de junho de 2012 15:45
    terça-feira, 12 de junho de 2012 15:44
  • sem dúvida, abaixo:

    <?xml version="1.0"?>
    <!--
      For more information on how to configure your ASP.NET application, please visit
      http://go.microsoft.com/fwlink/?LinkId=169433
      -->
    <configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">
      <configSections/>
      <connectionStrings>
        <add name="BRA_SIA.My.MySettings.SIAConecte" connectionString="Provider=Microsoft.Jet.OLEDB.4.0;Data Source=|DataDirectory|\SIA.mdb" providerName="System.Data.OleDb"/>
      </connectionStrings>
      <system.web>
        <customErrors mode="Off"/>
        <roleManager enabled="true"/>
        <globalization culture="pt-BR"/>
        <authentication mode="Forms">
          <forms name="ckLog" loginUrl="SIAlogin.aspx" defaultUrl="PRINCIPALequi.aspx" timeout="30" path="/"/>
        </authentication>
        <compilation debug="true" strict="false" explicit="true" targetFramework="4.0">
          <assemblies>
            <add assembly="System.Web.Extensions.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
            <add assembly="System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
            <add assembly="System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
          </assemblies>
        </compilation>
      </system.web>
    </configuration>

    Olavo, não sei se tem alguma relação, mas eu encriptei a conectionstrings no arquivo de publicação.


    terça-feira, 12 de junho de 2012 16:42
  • Wilson

    ai vai um dica, pode ser que funcione

    Altere a versão do do Seu Framework,  clique com o botão direito em cima do projeto web, escolha a ultima opção "Properties".

    na Aba "Application" altere o campo "Target Framework" para ".NET Framework 3.5" .

    feito isso salve e compila o projeto novamente, pelo que vi no seu Web.Config, pode ser que funcione se vc fizer essa alteração.

    Boa sorte ai amigão!


    Herbert Agles
    Se a resposta contribuiu com a sua necessidade, não se esqueça de marcá-la, assim você beneficiará outros usuários. Sua dúvida também pode ser as de outros!

    • Marcado como Resposta Wilson Boris terça-feira, 12 de junho de 2012 17:49
    terça-feira, 12 de junho de 2012 17:24
  • Herbert, sei lá que bicho foi esse, ao mudar o framework para 3.5 as mensagens aumentaram para 81 e ao retornar para 4.0 está zeradinho sem mensagens. Valeu pelo caminho, muito obrigado.
    terça-feira, 12 de junho de 2012 17:49