none
Consumir um serviço web em uma rede ponto-a-ponto RRS feed

  • Pergunta

  • Srs.,
    Eu criei um WebService com o visual studio 2008, porém o mesmo só funciona localmente, ou seja dentro do projeto que o executo ele abre a seguinte página: http://localhost:1118/servico.asmx. Porém coloquei o micro em um rede ponto-a-ponto. E gostaria de fazer o outro micro consumir esse serviço que criei localmente. Como faço para tornar isso possível.

    Dados adicionais:
    IP da máquina que criei o serviço (http://localhost:1118/servico.asmx): 192.168.0.1
    Essa máquina foi instalado o IIS 6.0 e não realizei nenhuma configuração especifica nele. Fiz todo o projeto no Visual Studio 2008.

    Na outra máquina, não sei se é o correto, tetei criar a mesma aplicação e na hora de acionar a web referencia, coloque o seguinte: http://192.168.0.1/servico.asmx. Ou seja, substitui o localhost pelo IP da máquina, porém ele não encontrou o serviço.

    Como posso tornar isso possível ?

    Desde já agradeço pela ajuda!

    Um abraço!
    domingo, 26 de abril de 2009 14:34

Todas as Respostas

  • Srs.,
    Eu criei um WebService com o visual studio 2008, porém o mesmo só funciona localmente, ou seja dentro do projeto que o executo ele abre a seguinte página: http://localhost:1118/servico.asmx. Porém coloquei o micro em um rede ponto-a-ponto. E gostaria de fazer o outro micro consumir esse serviço que criei localmente. Como faço para tornar isso possível.

    Dados adicionais:
    IP da máquina que criei o serviço (http://localhost:1118/servico.asmx): 192.168.0.1
    Essa máquina foi instalado o IIS 6.0 e não realizei nenhuma configuração especifica nele. Fiz todo o projeto no Visual Studio 2008.

    Na outra máquina, não sei se é o correto, tetei criar a mesma aplicação e na hora de acionar a web referencia, coloque o seguinte: http://192.168.0.1/servico.asmx. Ou seja, substitui o localhost pelo IP da máquina, porém ele não encontrou o serviço.

    Como posso tornar isso possível ?

    Desde já agradeço pela ajuda!

    Um abraço!

    Alguem sabe se é isso mesmo ???

    Obrigado!
    segunda-feira, 4 de maio de 2009 14:29
  • Vc esqueceu da porta http://192.168.0.1:1118/servico.asmx

    Se não estiver executando o web service pelo IIS, vc precisa abrir o VS e rodar o projeto para ele abrir o servidor local, veja a porta e faça o teste na outra máquina.

    Certifique q a rede esteja configurada corretamente tb. Veja se consegue "pingar" e acessar diretórios.


    Abs
    Bruno Gallego - Se este poste foi útil, por favor, classifique
    MCP - MCTS - MCDBA - MCPD.NET
    segunda-feira, 4 de maio de 2009 17:52