none
Webpart dentro de page RRS feed

  • Pergunta

  • Tenho o seguinte problema ao criar uma página dentro de um site.

    Crei uma content place holder na master page para inserir uma webart de imagem como banner do site. Porém Quando abro a página no sharepoint designer e coloco uma zona de webpart dentro da content place holder e salvo, quando vou visualizar a pagina no navegador a zona de webpart não aparece, se eu inserir um conteudo qualquer tipo texto, o conteudo que eu inseri dentro da content place holder aparece. Momenteneamente eu fiz uma copia da default do site onde as zonas de webpart aparecem normalmente, porém acredito que não seja a melhor prática pois o procedimento fica muito manual.

     

    Qual seria a melhor solução para isso?

    Obrigado desde já.

    quarta-feira, 11 de agosto de 2010 17:28

Todas as Respostas

  • Olá Huxley,

    Boa noite, tudo bem?

    Cara, você não deveria ter uma WebPart Zone dentro de uma Master Page, pois a WebPart Zone tem como um dos objetivos ser um container para os usuários adicionarem via interface as WebParts em um determinado lugar pré-definido de uma página.

    Porque você não adiciona essa WebPart Zone diretamente na página?

    Abraços!

    Wagner Amorim
    --
    SharePoint Specialist
    Microsoft MCP, MCTS e MCPD
    --
    http://www.doneit.com.br

    http://www.canalsharepoint.com.br
    http://waamorim.spaces.live.com
    Wagner M. Amorim
    quarta-feira, 11 de agosto de 2010 22:31
  • Wagner eu não criei a Webpart-zone dentro master, só a content place para poder criar a webpartzone dentro de outras páginas, porém quando vou criar a zona de webpart dentro de uma page a zona de webpart não aparece no modo de edição no navegador. mas se eu inserir outro conteúdo que não seja uma Webpart zone, tipo um texto esse texto aparece. outro detalhe é que a página default.aspx eu criei essa webpartzone tranquilamente e enxergo ela no modo de edição.

    qual a diferença entre a página default.aspx e uma page que crio na biblioteca de paginas?

    quinta-feira, 12 de agosto de 2010 16:42
  • Olá Huxley,

    Bom dia!

    Legal, qual a versão do seu SharePoint? Você está inserindo a WebPart Zone através do SharePoint Designer? Essas Biblioteca de páginas que está utilizando está criando qual tipo de página? O Modelo de Pagina utilizado na criação da Biblioteca de Documentos deve ser "Página de WebPart".

    Tenta isso e me avisa. :)

    Abraços!

    Wagner Amorim
    --
    SharePoint Specialist
    Microsoft MCP, MCTS e MCPD
    --
    http://www.doneit.com.br

    http://www.canalsharepoint.com.br
    http://waamorim.spaces.live.com
    Wagner M. Amorim
    sexta-feira, 13 de agosto de 2010 10:24
  • Olá Wagner,

    Primeiramente obrigado pelo auxílio.

    vamos lá:

    *Uso Sharepoint Server 2010

    *WebPart Zone através do SharePoint Designer? - SIM

    se eu criar uma página de webpart o menu não aparece, eu gostaria que o menu aparece-se o que está pegando é o seguinte eu não consigo, na verdade até consigo criar a zona de webpart dentro da content-place holder que criei na master porém quando salvo. e visualizo no navegador não aparece ou seja não consigo inserir a webpart de maneira alguma mais isso somente se for na parte superior da página onde eu criei a content-place holder na master se eu criar dentro da area de conteudo da page funciona perfeitamente novas zona de webpart.

    a default.aspx mostra essa zona perfeitamente existe algum motivo especifico para não aparecer dentro da page são muito distintas uma da outra, tendo em vista que usam a mesma master, pelo menos assim eu acho, não sei ao certo.

    obrigado, aguardo teh + boa noite.

    sexta-feira, 13 de agosto de 2010 22:40