locked
Alguém explica: =soma(A1>=A2;3;C1:C3) RRS feed

  • Pergunta

  • Vi numa apostila para concurso esta questão. Não entendi o porque da resposta. Alguém sabe explicar? Os dados da planilha são estes:

    A1=10 A2=5  A3=2 A4=7
    B1=2  B2= 0 B3=4 B4=9
    C1=3 C2=8 C3=2 C4=3
    D1=1 D2=0 D3=10 D4=0

    A resposta apresenta 12. E não entendi o porque. Tenho uma idéia, mas não sei como provar que é a correta.
    É correto pensar que (A1>=A2) Resulta = 1. Soma este 1 + 3 e mais o resultado da soma de c1:c3?
    sábado, 23 de janeiro de 2010 02:52

Todas as Respostas

  • Olá
    =soma(a1>=A2;3;C1:C3)

    vc está somando os valores
    no meu o resultado é 17
    Porque

    A1>=A2 = 1
    +
                     3
    C1:C3   = 13

    então 17
    Qual era sua intenção
    não era assim?

    {=soma(se(a1>=A2;3;C1:C3))}

    dai o resultado daria 3

    OK


    Wesley
    • Sugerido como Resposta Quer Ob Uba domingo, 21 de fevereiro de 2010 17:53
    terça-feira, 26 de janeiro de 2010 16:23
  • Minha gratidão Wesley por sua atenção e resposta. Eu fui procurar um amigo para me explicar, mas ele não estava. Na casa dele, usei o computador e publiquei a pergunta. Pouco tempo depois ele chegou e me explicou. Eu não estava entendendo o porque do resultado do gabarito. Minha intenção era saber o porque a resposta sendo que por mais que eu lesse a questão, não conseguia obter o resultado. No Excel, sim se obtem, mas, fazendo os cálculos numa prova de concurso, eu não chegava a respostas e sugestões propostas. Esta era minha intenção!
    Meu amigo me explicou assim:

    =SOMA(A1>=A2 … ) esta parte da fórmula pode ter apenas duas resposta que são:

    1. Se for verdadeira, ou seja, se A1 contém um número maior ou igual a A2 o resultado é igual a 1 e será somado com 3 + o resultado da soma do intervalo C1:C3
    2. Se for falso, ou seja, se A1 contém um número menor ou igual a A2, o resultado é igual a 0 (zero) e será somado com 3+ o resultado da soma do intervalo C1:C3.

    Soma-se 1 + 3, mais a soma do intervalo de células C1:C3= e o resultado é igual a 12, mas, olhando a questão, vi que coloquei um número errado, por isto o seu resultado é diferente da pergunta do concurso que apresenta 12... por isto a diferença, mas sua explicação, é verdadeira e igual a que obtive com meu amigo.

    Só tenho que agradecer!

    sábado, 6 de fevereiro de 2010 16:29