locked
formula via macro RRS feed

  • Pergunta

  • + uma duvida...

     

    eu to usando do seguinte codigo:

    Code Snippet
            shtAux.Cells(25, 18) = "=SE($O$1>1;$Q$1;$Q$2)"

     

     


    só q quando eu adicino pela macro da erro:

    Erro de definição de aplicativo ou de definição de objeto

     

    alguem sabe de uma solução pra isso?

    quarta-feira, 30 de abril de 2008 19:02

Respostas

  • Tente desta forma:

    Code Snippet

    shtAux.Cells(25, 18).Formula = "=IF($O$1>1,$Q$1,$Q$2)"

     

     

    Dois detalhes

    1. Precisa indicar que é uma fórmula, pois a propriedade padrão para Cells é Value

    2. As fórmulas em VBA devem ser inseridas em inglês.

    Dica: Use o gravador de macro para observar a sintaxe adequada para a fórmula.

    [ ]s

     

    quarta-feira, 30 de abril de 2008 19:30
  • Cara, a sintaxe para fórmula via macro é um pouco diferente...Você tem que trocar o SE por IF, o ";" por ",". Olha um exemplo bem simples pra você ter uma idéia:

     

    Sheets("plan1").Cells(5, 1).Formula = "=IF(A2>1,0,2)"

     

    Veja se isto ajuda...

     

    Rafael

    quarta-feira, 30 de abril de 2008 19:40

Todas as Respostas

  • Tente desta forma:

    Code Snippet

    shtAux.Cells(25, 18).Formula = "=IF($O$1>1,$Q$1,$Q$2)"

     

     

    Dois detalhes

    1. Precisa indicar que é uma fórmula, pois a propriedade padrão para Cells é Value

    2. As fórmulas em VBA devem ser inseridas em inglês.

    Dica: Use o gravador de macro para observar a sintaxe adequada para a fórmula.

    [ ]s

     

    quarta-feira, 30 de abril de 2008 19:30
  • Cara, a sintaxe para fórmula via macro é um pouco diferente...Você tem que trocar o SE por IF, o ";" por ",". Olha um exemplo bem simples pra você ter uma idéia:

     

    Sheets("plan1").Cells(5, 1).Formula = "=IF(A2>1,0,2)"

     

    Veja se isto ajuda...

     

    Rafael

    quarta-feira, 30 de abril de 2008 19:40