none
Problema SSMS e replicação RRS feed

  • Pergunta

  • Bom dia a todos.

    Estava adicionando alguns artigos na replicação transacional que temos e de repente o SSMS fechou. Quando abri novamente, apareceu a seguinte mensagem no status da sincronização: "The subscription to this publication is not active yet. No user action is required."

    Ja reiniciei a replicação e não funcionou. Alguém sabe o que pode ser? Aparentemente está tudo normal, mas o "Undistributed Commands" não para de crescer.

    Obrigado.

    []'s
    quarta-feira, 14 de outubro de 2009 14:12

Respostas

Todas as Respostas

  • Molina,

    Você esta utilizando o SQL Server 2005?

    A replicação esta funcionando?
    Pedro Antonio Galvão Junior - MVP - Windows Server System - SQL Server/Coordenador de Projetos/DBA
    quarta-feira, 14 de outubro de 2009 16:44
    Moderador
  • Olá Junior.

    Aparentemente sim, ela funciona. Ela só não manda os dados para o outro servidor. Fica com essa mensagem mostrando no status da sincronização.

    Estou usando o SQL Server 2005 SP3.

    []'s
    quarta-feira, 14 de outubro de 2009 16:50
  • Molina,

    Você já verificou as configurações no servidor assinante?
    Pedro Antonio Galvão Junior - MVP - Windows Server System - SQL Server/Coordenador de Projetos/DBA
    quarta-feira, 14 de outubro de 2009 17:13
    Moderador
  • Já sim, está tudo certo.

    Perguntei em outros fóruns e as respostas foram de excluir e criar de novo a replicação, infelizmente.

    []'s
    quarta-feira, 14 de outubro de 2009 17:22
  • Molina,

    A minha recomendação também é esta, recriar a replicação.
    Pedro Antonio Galvão Junior - MVP - Windows Server System - SQL Server/Coordenador de Projetos/DBA
    quarta-feira, 14 de outubro de 2009 18:50
    Moderador
  • É o que irei fazer.

    Obrigado.

    []'s
    quarta-feira, 14 de outubro de 2009 18:57
  • Patricio,

    Ok, ficamos no aguardo.
    Pedro Antonio Galvão Junior - MVP - Windows Server System - SQL Server/Coordenador de Projetos/DBA
    quarta-feira, 14 de outubro de 2009 20:14
    Moderador
  • Olá Junior.

    Gerei novamente a replicação e tudo funcionou normalmente.

    Obrigado.

    []'s
    quinta-feira, 15 de outubro de 2009 18:37
  • Molina,

    Obrigado pelo retorno.
    Pedro Antonio Galvão Junior - MVP - Windows Server System - SQL Server/Coordenador de Projetos/DBA
    sexta-feira, 16 de outubro de 2009 01:28
    Moderador