none
Problemas com o Model RRS feed

  • Pergunta

  • Senhores

    Tenho uma ação que aceita os verbos GET e POST, ao chama-lo através do POST eu passo um objeto do meu modelo (na verdade um View Model), porém recebo a seguinte mensagem de erro:

    An item with the same key has already been added.

    o traceback é bem genérico e não me deu muitas pistas, alguém teria alguma idéia de onde estou errando?

    quarta-feira, 2 de fevereiro de 2011 16:17

Todas as Respostas

  • Rodrigo, posta o código ai pra ficar mais fácil para analisar seu problema.
    quarta-feira, 2 de fevereiro de 2011 16:36
  • na minha pasta model eu tenho uma classe básica, como:

     

    public class MeuModelo
    {
     public int Id { get; set; }
     public string Nome { get; set; }
    }
    

    e no meu controller os métodos:

    [httpGet]
    public ActionResult Criar()
    {
     MeuModelo _modelo = new MeuModelo();
     return View(_modelo);
    }
    
    [httpPost]
    public ActionResult Criar(MeuModelo modelo)
    {
     // ele sequer chega a executar qualquer 
     // e a mensagem é exibida
    }

    e a página

    @model MenosAinda.WebApp.Models.MeuModelo
    
    @using (Html.BeginForm()) {
    	@Html.HiddenFor(model => model.Id)
    
    	@Html.LabelFor(model => model.Nome)
        
    	@Html.EditorFor(model => model.Nome)
    	@Html.ValidationMessageFor(model => model.Nome)
    
    	<input type="submit" value="vai" />
    }

    • Editado RodrigoBraga quarta-feira, 2 de fevereiro de 2011 17:28
    quarta-feira, 2 de fevereiro de 2011 16:43
  • Coloca ai tbm o aspx
    quarta-feira, 2 de fevereiro de 2011 17:22
  • Editei a mensagem acima com o trecho da página
    quarta-feira, 2 de fevereiro de 2011 17:29
  • Rodrigo, tenta colocar assim:

    @using (Html.BeginForm("NomeController","Criar")) {
    	@Html.HiddenFor(model => model.Id)
    
    	@Html.LabelFor(model => model.Nome)
      
    	@Html.EditorFor(model => model.Nome)
    	@Html.ValidationMessageFor(model => model.Nome)
    
    	<input type="submit" value="vai" />
    }
    
    

    quarta-feira, 2 de fevereiro de 2011 18:04
  • bizarro cara... zerei tudo e refiz (como era pequeno mesmo) e simplesmente funcionou!

     

    deveria ter alguma gordura que fugiu aos meus olhos!

     

    Valeu!

    quinta-feira, 3 de fevereiro de 2011 18:36