locked
Datas RRS feed

  • Pergunta

  • Boas estou com um problema que é o seguinte:
     
    Tenho na Coluna "B" Texto, celulas em branco e datas.
    Na coluna "C" Produtos
    Na coluna "D" quantidades de produto.
    Fiz a função SOMA.SE.S em relação a soma de produto e quantidade para saber quntos produtos vendi do mesmo nome até aqui tudo certo.
    Agora queria colocar outro critério em relação as data se por exemplo < 30-02-2010 daria a quantidade vendida só em Janeiro e por ai fora.
    Será que tem forma de fazer isto?
     
    Obrigado desde já
    sexta-feira, 24 de dezembro de 2010 12:47

Todas as Respostas

  • Tente assim... http://www.officevb.com/2010/12/respondendo-perguntas-com-o-excel.html Att
    Bruno Silva Leite
    officevb.com
    sexta-feira, 24 de dezembro de 2010 13:10
  • tem sim

     

    No caso vc usará o somases() ou seja, tem que ter mais de uma condição.


    A primeira condição é a que vc já tem, no caso, o produto ser tal

     

    A segunda condição é a data menor

    a constante para a data é "30/02/2010"+0

     

    Isso serve para converter a string em data (o mais zero é o pulo do gato) 

     

    Experimente.

     

     


    João Eurico Consultor Manguetown - Brazil
    sexta-feira, 24 de dezembro de 2010 13:17
  • Só um adendo, o SOMASES somente funcionará se o Excel for o 2007 ou posterior. Nas versões anteriores o ideal é utilizar o SOMARPRODUTO.
    Bruno Silva Leite
    officevb.com
    sexta-feira, 24 de dezembro de 2010 13:19
  • Desculpa mas não estou a entender eu tenho esta formula com SOMA.SE.S

    =SOMA.SE.S(Encomendas_2011!F:F;Encomendas_2011!D:D;B5) agora gostava de filtrar por data.

    Como é que eu faço, não estou a conseguir como está a dizer

    sexta-feira, 24 de dezembro de 2010 15:22
  • sim o meu Excel é 2010
    sexta-feira, 24 de dezembro de 2010 15:22
  • Seu Excel parece ser português de Portugal. Pode ser que os separadores entre os parâmetros seja , ao invés de ;

    Experimente trocar.


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br
    domingo, 26 de dezembro de 2010 14:51
  • Não dá da mesma.

    Estou a entrar em parafuso!

    o que posso fazer?

    segunda-feira, 27 de dezembro de 2010 15:31
  • Tente algo do tipo:

    =SOMARPRODUTO((B1:B10>DATA(2009;12;25))*(B1:B10<DATA(2010;12;25));--(C1:C10="Produto");D1:D10)

    Onde lê-se as fórmulas DATA(2009;12;25)DATA(2010;12;25), pode-se substituir por uma referência à uma célula que contenha uma data.


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br
    segunda-feira, 27 de dezembro de 2010 20:02