none
IpOverUsbSvc - Nokia Lumia 520 with windows 7 and 8.1 RRS feed

  • Pergunta

  • Boa tarde a todos, possuo uma licencia de desenvolvedor para o sistema windows phone da microsoft, onde poderei publicar minhas aplicações a fins de comercialização ou divulgação.

    Dessa forma comecei efetuar desenvolvimento de diversas aplicações para o produto utilizando visual studio 2013 licenciado somente para um único usuário, que no caso sou eu. Dentro disso fui desenvolvendo uma aplicação mas para estar o emulador demonstra-se não ser tão eficiente por diversos problemas com rede e velocidade de sua emulação e não simula um ambiente verdadeiro de utilização. Então por esse fato adquirir um produto da Nokia empresa recentemente adquirida pela microsoft, onde adquirir um nokia lumia 520 com sistema operacional windows 8 black e recentemente me inscrevi ao plano do windows 8.1 preview como desenvolvedor que já está sendo utilizado por mim o novo sistema operacional windows phone 8.1.

    Dentro dessa nova tomada de tecnologia da microsoft, acabei desenvolvendo minhas aplicações visando o windows phone 8.1 logicamente não mudou muita coisa no desenvolvimento, mas ok.

    Até ai tudo bem, ai fui tentar testar a aplicação de forma local em meu celular recentemente adquirido para esse proposito onde visava a utilização para teste de aplicações. Dentro disso instalei o dispositivo no Windows 7 e no Windows 8.1 "educacional". Ao conectar o dispositivo celular e abrir ao executar o aplicativo de registro do windows phone 8.1 que vem instalando com SDK 8.1, apresentou o seguinte erro.

    Status: Unable to connect to a phone. Make sure that Windows Phone IP over USB Transport (IpOverUsbSvc) service is running.

    Dentro disso tentei diversas correções como entrar no registro da USB como recomendado pela microsoft e verificar se todos os registros estão demarcados de forma correta que no caso estavam, tentei ir em Serviços do windows para verificar se o dispositivo estava iniciado, o mesmo desliguei o dispositivo, reiniciei o pc voltei em serviços quando o pc ligou reiniciei o dispositivo em serviços, juntamente com o aparelho "hardware" como recomendado pela microsoft, e fiz tudo necessário como recomendado pela microsoft e nada funcionou.

    Bom procurei na comunidade e nada, reinstalei o visual studio o sdk e etc... e nada, bom removi portas de impressora, modem e outros e nada também.

    Agora não sei o que fazer, entrei em contato com o suporte microsoft me informaram que não sabia o que fazer além de seguir os passos sugeridos, tentei utilizar uma maquina virtual e nada, agora não sei o que fazer preciso de ajuda.

    O suporte me sugeriu enviar a aplicação como beta que leva até 4 horas para ser aprovada e assim baixada direto da loja, pois ela não sabia mais o que fazer ou ajudar, sugeri um trabalho remoto e não quis ajudar remotamente, o problema de subir é que imagine estou com uma aplicação beta para mim, imagine a cada hora ter que ficar publicando-a na loja beta e esperando 4 horas, pois um desenvolvimento leva muitas mudanças a cada instante.

    Bom agora estou aguardando o suporte adequado da microsoft ou comunidade pois é uma vergonha a empresa chegar ao ponto que nem um dos três produtos funcione, windowsphone 8.1, windows 7 e 8 e o hardware dela Nokia lumia 520.

    Aguardando ajuda e suporte.

    Agradeço a todos.

    sexta-feira, 23 de maio de 2014 20:43

Respostas

  • Olá, Luiz.

    Olha, pode descartar o Windows 7 pois só se desenvolve para Windows Phone 8.x no Windows 8.x.

    O problema ocorre também quando você tenta emular usando o VS2013 e Windows 8?

    Você registrou seu aparelho para poder fazer o deploy nele?

    Abraços! 

    sábado, 24 de maio de 2014 13:56

Todas as Respostas

  • Olá, Luiz.

    Olha, pode descartar o Windows 7 pois só se desenvolve para Windows Phone 8.x no Windows 8.x.

    O problema ocorre também quando você tenta emular usando o VS2013 e Windows 8?

    Você registrou seu aparelho para poder fazer o deploy nele?

    Abraços! 

    sábado, 24 de maio de 2014 13:56
  • Quero registrar o aparalho para poder testar minha aplicação sem ter que ficar enviando toda hora para a loja BETA que leva até 4 horas para subir.

    E sim fazer um Debug test e Deploy.

    A aplicação é simples da copa do mundo, mas é algo que quero que esteja 100%.

    segunda-feira, 26 de maio de 2014 20:27
  • Sem registrar você não consegue fazer o deploy no device.

    Segue o link que explica como registrar seu aparelho: registrar aparelho

    Lembrando que você pode ter até três dispositivos registrados ao mesmo tempo.

    Boa sorte!

    Atenciosamente,

    terça-feira, 27 de maio de 2014 02:28