none
Demora no IIS RRS feed

  • Pergunta

  • Galera bom dia estou desenvolvendo uma aplicação em ASP.NET MVC , 

    só que quando eu compilo ou recompilo o projeto, demora DEMAIS pra recarregar a pagina no navegador.

    Alguém sabe o que pode ser esse problema?


    Rodrigo de Farias

    quinta-feira, 15 de maio de 2014 14:53

Respostas

  • Se sua máquina está servindo com IIS tem que ver a qtde de memória nela, pois servidores de IIS tem que ter muita memória e verifique tb os serviços que estão rodando na sua máquina.

    Se vc está apenas executando debuga para ver o que está acontecendo talvés seu sistema esteja fazendo algo inesperado, pq comigo isso nunca aconteceu.

    Pode ser alguma consulta que vc faça antes de carregar a página inicial que esteja demorando demais, no banco de dados verifique suas consultas e crie índices assim suas consultas ficaram mais rápidas e evite consultas "select * from "


    Junior

    segunda-feira, 2 de junho de 2014 14:37

Todas as Respostas

  • Boa tarde Rodrigo, essa demora é normal, mas somente na primeira vez.

    Pois quando você compila e recompila, o visual studio tem que gerar todas as DLL, limpar cache, limpar memoria e tals.

    Mas se isso acontece sempre por ser que algum trecho de código esteja impactando no processamento.

    Att.

    Rodolfo Oliveira

    • Sugerido como Resposta Diego Murakami quinta-feira, 15 de maio de 2014 19:28
    quinta-feira, 15 de maio de 2014 16:09
  • Bom dia Rodolfo!

    Entendo que a após recompilar demora mais para recarregar, o mas o problemas é que esta demorando cerca de 58 segundos para recarregar a página!


    Rodrigo de Farias

    segunda-feira, 2 de junho de 2014 13:18
  • Rodrigo eu tenho um site onde tem muito acesso, e sempre que ele é atualizado dependendo da qtde de usuários logados ele demora até 40 minutos para reiniciar após a atualização, tanto que evito fazer atualizações no horário do expediente, sempre faço ou muito cedo ou mais tarde.

    O que descobrir é que o IIS demora pq ele tem que tipo deslogar todos os usuários que estão logados e quantos mais tiverem logados maior a demora.


    Junior

    segunda-feira, 2 de junho de 2014 13:47
  • Entendo, mas o que citei acima esta acontecendo em minha máquina, não tem nenhum usuário logado nem nada , será que ainda assim é normal?

    Rodrigo de Farias

    segunda-feira, 2 de junho de 2014 14:19
  • Se sua máquina está servindo com IIS tem que ver a qtde de memória nela, pois servidores de IIS tem que ter muita memória e verifique tb os serviços que estão rodando na sua máquina.

    Se vc está apenas executando debuga para ver o que está acontecendo talvés seu sistema esteja fazendo algo inesperado, pq comigo isso nunca aconteceu.

    Pode ser alguma consulta que vc faça antes de carregar a página inicial que esteja demorando demais, no banco de dados verifique suas consultas e crie índices assim suas consultas ficaram mais rápidas e evite consultas "select * from "


    Junior

    segunda-feira, 2 de junho de 2014 14:37