none
Aplicativo 64 bits rodar em 32 bits. RRS feed

  • Pergunta

  • Estou trabalhando com VS2012,  C#, com windows 7 64 bits. Meus aplicativos desenvolvidos funcionam perfeitamente em micros com sistema operacional 64 bits. Não estou conseguindo colocar para rodar em micros com sistema 32 bits. Estou tentando compilar em x86, Any PC mas só funciona em micros com Sistema Operacional 64 bits. Alguém pode me indicar o caminho das pedras. Obrigado, abraço a todos!
    quarta-feira, 8 de janeiro de 2014 21:51

Respostas

  • A dll que contem o namespace FirebirdSql deve ser .Net 4.5.

    Você deve adquirir uma versão dela para .Net 4.0 e então adiciona-la como referencia no seu projeto.


    Herbert Lausmann

    • Sugerido como Resposta Giovani Cr quinta-feira, 9 de janeiro de 2014 15:00
    • Marcado como Resposta Giovani Cr sexta-feira, 17 de janeiro de 2014 19:07
    quinta-feira, 9 de janeiro de 2014 09:54
  • Bom dia, tente alterar para o .Net Framework 4.0 e não 4.0 Cliente Profile

     

    Se a Resposta foi útil, por favor marque como válida assim esta contribuindo para gratificar todo o esforço de nossos colegas, Abraço.


    Paulo Caleffi

    • Marcado como Resposta Giovani Cr sexta-feira, 17 de janeiro de 2014 19:07
    segunda-feira, 13 de janeiro de 2014 09:54

Todas as Respostas

  • Estou trabalhando com VS2012,  C#, com windows 7 64 bits. Meus aplicativos desenvolvidos funcionam perfeitamente em micros com sistema operacional 64 bits. Não estou conseguindo colocar para rodar em micros com sistema 32 bits. Estou tentando compilar em x86, Any PC mas só funciona em micros com Sistema Operacional 64 bits. Alguém pode me indicar o caminho das pedras. Obrigado, abraço a todos!

    Com novas pesquisas descobri que o problema parece que não está no 64 bits mas sim no Framework 4.5 que não roda no windows xp. Estou tentando passar para Framework 4.0 mas aparece um monte de erro.

    The type or namespace name 'FirebirdSql' could not be found (are you missing a using directive or an assemble reference?)

    Alguém pode me ajudar? Obrigado!

    quinta-feira, 9 de janeiro de 2014 09:45
  • A dll que contem o namespace FirebirdSql deve ser .Net 4.5.

    Você deve adquirir uma versão dela para .Net 4.0 e então adiciona-la como referencia no seu projeto.


    Herbert Lausmann

    • Sugerido como Resposta Giovani Cr quinta-feira, 9 de janeiro de 2014 15:00
    • Marcado como Resposta Giovani Cr sexta-feira, 17 de janeiro de 2014 19:07
    quinta-feira, 9 de janeiro de 2014 09:54
  • Bom dia, tente alterar para o .Net Framework 4.0 e não 4.0 Cliente Profile

     

    Se a Resposta foi útil, por favor marque como válida assim esta contribuindo para gratificar todo o esforço de nossos colegas, Abraço.


    Paulo Caleffi

    • Marcado como Resposta Giovani Cr sexta-feira, 17 de janeiro de 2014 19:07
    segunda-feira, 13 de janeiro de 2014 09:54