none
Erro com o Pin-Pad Redecard e Cancelamento Visanet RRS feed

  • Pergunta

  • Pessoal, boa tarde...

    Estou recorrendo ao fórum para ver se consigo sair dessa enrascada...
    Estou com dois problemas:

    1.) O primeiro é com a configuração do pin-pad no gerenciador Redecard. Estou usando um Ingenico 3070 que funciona corretamente no gerenciador Amex e Visanet porém nas configurações da Redecard ele me dá a seguinte mensagem: "Erro ao Inicializar porta COM [02]".
    Já tentei de tudo, troquei a porta com a impressora fiscal, mexi num tal arquivo sitconf.ini, desinstalei/instalei novamente mas a coisa não vai... e com a Amex e Visanet funciona corretamente... o pin está na COM 4... alguém já passou por isso e conseguiu resolver?

    2.) O segundo problema é no teste de corte de energia do micro, com a VisaNet. Quando volto a minha aplicação no ar, e mando o CNC eu obtenho a mensagem ao operador "OPERACAO CANCELADA (erro PGCli 107)", e quando tento confirmar  o cancelamento, obtenho o erro "Erro ao iniciar TEF DISCADO (22)". Como estou trabalhando em ambiente de testes, ainda não conectei à linha telefônica, pois penso que da mesma forma que o processo de transação da venda é realizado normalmente offline eu acho que o cancelamento deveria também... estou errado?

    Por favor, não sei mais o que faço pra resolver isso e dar andamento nos meus testes...

    Grato por qualquer ajuda...
    Daniel
    segunda-feira, 9 de novembro de 2009 20:57

Respostas

  • Bom dia!

    Seguinte, eu também tenho o Vista instalado, mas para homologação não pode ser o Vista nem o Windows 7.

    Também tive esse problema do pinpad com o Redecard não comunicar e com todos os outros sim. Infelizmente, não descobri o problema, mas em todos os XP que eu instalei funcionou o pinpad no Redecard. Não sei se foi coincidência, mas funcionou.

    Quanto ao segundo problema, seria interessante foi ligar na SevenPDV e reportar o problema, pois aparentemente, parece ser um problema no módulo.

    T+
    • Marcado como Resposta Daniel Silveira terça-feira, 10 de novembro de 2009 10:35
    terça-feira, 10 de novembro de 2009 10:24

Todas as Respostas

  • Boa noite!

    Qual SO vc está utilizando?

    T+
    segunda-feira, 9 de novembro de 2009 22:23
  • Olá Fábio... bom dia...

    Estou utilizando o Vista Business, com SP2.
    Seria esse o problema??
    Daniel
    terça-feira, 10 de novembro de 2009 10:13
  • Bom dia!

    Seguinte, eu também tenho o Vista instalado, mas para homologação não pode ser o Vista nem o Windows 7.

    Também tive esse problema do pinpad com o Redecard não comunicar e com todos os outros sim. Infelizmente, não descobri o problema, mas em todos os XP que eu instalei funcionou o pinpad no Redecard. Não sei se foi coincidência, mas funcionou.

    Quanto ao segundo problema, seria interessante foi ligar na SevenPDV e reportar o problema, pois aparentemente, parece ser um problema no módulo.

    T+
    • Marcado como Resposta Daniel Silveira terça-feira, 10 de novembro de 2009 10:35
    terça-feira, 10 de novembro de 2009 10:24
  • Olá Fábio, bom dia amigo...

    Impressionante isso... temos que regredir para podermos homologar nosso software?
    Vou entrar em contato com a Seven PDV...

    Obrigado amigo, valeu mesmo.

    []s
    Daniel
    terça-feira, 10 de novembro de 2009 10:35
  • Bom dia!

    Então, homologamos nosso sistema. Mas chegando lá estavamos com Windows Vista e depois de alguns roteiros de teste o homologador viu que era o Vista e mandou parar, e disse que não poderia ser com o Vista. Ai foi a correria para o XP :)

    T+
    terça-feira, 10 de novembro de 2009 10:39
  • Certo, mas aí você perdeu né? Teve que remarcar outra homologação? Ou deu tempo de fazer tudo isso no mesmo dia?
    Se eu entro numa dessa, to lascado, pois estou no interior de SP...


    Daniel
    terça-feira, 10 de novembro de 2009 10:43
  • Deu pra fazer tudo isso no mesmo dia :) Não precisou marcar outra homologação.
    terça-feira, 10 de novembro de 2009 10:49
  • Beleza amigo... obrigado pelos esclarecimentos.
    Boa sorte.

    []s
    Daniel
    terça-feira, 10 de novembro de 2009 10:51
  • seguinte nao entendo muito disso

    mas a situação da com2 coloca o pind pad na com 2 e configura tudo na porta 2

    quinta-feira, 27 de maio de 2010 16:26