none
Dúvida RRS feed

  • Pergunta

  • Pessoal, bom dia!!

    Me perdoem se eu estiver fazendo a pergunta no lugar errado, é que não sei mais onde pesquisar, preciso compara 2 abas de uma planilha que possuem as colunas "Docente", "Titulação" e "Regime de Trabalho", em uma existem professores novos (que foram contratados no mês vigente) e na outra a situação anterior dos professores (situação até o mês passado), agora eu preciso comparar a "Titulação" e o "Regime de Trabalho" das duas abas colocando "↑" para a titulação que tiver aumentado (Mestre para Doutor, por exemplo) e "↓" para as que forem "rebaixadas", porém como as duas abas possuem professores a mais, ou a menos, não sei como realizar esta comparação.

    Já tentei fazer uma junção de PROC + SE; SE + PROCV + ÉERRO; SE + ÉERRO +PROCV + PROC 

    Mas nada funciona!!! \o/

    Alguém pode me ajudar??

    E mais uma vez peço perdão caso esteja fazendo a pergunta no lugar errado!! =/

    terça-feira, 27 de setembro de 2016 13:33

Todas as Respostas

  • Minha sugestão para fazer isso:

    1) Numa nova planilha, copie na mesma coluna a lista de Docentes das duas planilhas, e aplique a ferramenta "REMOVER DUPLICATAS" que está disponível na aba DADOS. Dessa forma você terá a relação de todos os docentes sem repetição.

    2) Nas coluna a direita, nomeie o cabeçalho TITULAÇÃO ANTERIOR e TITULAÇÃO ATUAL, e para cada coluna aplique o PROCV das respectivas planilhas, com a fórmula neste modelo: =SEERRO(PROCV(A2;plan_Anterior!A:C;2;0);"-") e =SEERRO(PROCV(A2;plan_Atual!A:C;2;0);"-"). Estas fórmulas são só modelos para você adaptar a realidade do seu arquivo.

    3) Se a relação de professores for pequena, você pode fazer na mão mesmo a comparação. Ou você pode criar uma tabela com o grau da titulação em número para servir de referência para comparação entre o atual e o anterior, para poder aplicar a diferença. Exemplo, Mestre é escala 3 e doutor é escala 4, então crie novas colunas para trazer esses valores com o PROCV para então fazer a diferença (4-3 = 1, ou seja, "↑").

    Não é necessário recorrer ao VBA para este tipo de análise.


    Rafael Kamimura - http://excelmaniacos.com

    terça-feira, 27 de setembro de 2016 14:42