none
Módulo de Compatibilidade no IE8, pq não aparece? RRS feed

  • Pergunta

  • Olá pessoal,

    O meu problema é: o meu sistema C# .NET quando roda localmente o botão de módulo de compatibilidade do IE8 aparece, entretanto quando publico no servidor de desenvolvimento (da empresa que trabalho) o botão não aparece!

    Pq preciso do  do botão: a aplicação é renderizada corretamente na maioria dos browsers, entretanto no IE8 não, exceto se acionar o modo de compatibilidade, logo é mais vantagem usar esta funcionalidade do IE8 do que modificar o sistema.

    Alguém sabe a resposta?


    , grato!


    • Movido AndreAlvesLima sexta-feira, 29 de janeiro de 2010 14:32 Migrado de .Net Dvlp Geral (De:.NET Development - Geral)
    quarta-feira, 27 de janeiro de 2010 18:06

Respostas

  • Boa tarde Caio,


    Se o seu chefe aceita que o usuário só altere o modo de visibilidade você é um cara sortudo hehehehe...

    Creio que com essa tag no cabeçalho das suas páginas você forçe ele(ie 8) a renderizar no modo IE 7:
    <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7"/>

    Mais detalhes:
    http://msdn.microsoft.com/en-us/library/cc817570.aspx



    Abraço
    • Editado Charles Camargo quarta-feira, 27 de janeiro de 2010 18:31 faltou uma tag
    • Sugerido como Resposta Charles Camargo quarta-feira, 27 de janeiro de 2010 23:32
    • Marcado como Resposta AndreAlvesLima sexta-feira, 29 de janeiro de 2010 14:31
    quarta-feira, 27 de janeiro de 2010 18:30

Todas as Respostas

  • Boa tarde Caio,


    Se o seu chefe aceita que o usuário só altere o modo de visibilidade você é um cara sortudo hehehehe...

    Creio que com essa tag no cabeçalho das suas páginas você forçe ele(ie 8) a renderizar no modo IE 7:
    <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7"/>

    Mais detalhes:
    http://msdn.microsoft.com/en-us/library/cc817570.aspx



    Abraço
    • Editado Charles Camargo quarta-feira, 27 de janeiro de 2010 18:31 faltou uma tag
    • Sugerido como Resposta Charles Camargo quarta-feira, 27 de janeiro de 2010 23:32
    • Marcado como Resposta AndreAlvesLima sexta-feira, 29 de janeiro de 2010 14:31
    quarta-feira, 27 de janeiro de 2010 18:30
  • Chefe bom!!!


    VLW

    quarta-feira, 27 de janeiro de 2010 19:31
  • Prezado,

    Estou migrando seu post para o fórum de Web Development Geral.

    Por favor, nas próximas vezes em que for postar alguma dúvida relacionada a desenvolvimento Web ou Asp.Net, poste em um dos fóruns abaixo da categoria "Web Development".

    Obrigado!


    André Alves de Lima // Visite o meu site: http://andrealveslima.spaces.live.com //
    sexta-feira, 29 de janeiro de 2010 14:32