none
MVC 4 Mobile - CSS RRS feed

  • Pergunta

  • Boa Tarde,

    Eu criei uma aplicação em MVC 4 para mobile, e testando local os CSS estão normais.

    Ao publicar o projeto no servidor, ele apareceu sem estilo algum.

    Alguém sabe o que está acontecendo?

    segunda-feira, 30 de setembro de 2013 19:07

Todas as Respostas

  • Confere os arquivos no servidor, verifique se você levou os CSS, olhe o código fonte a página pra verificar se rEALMENTE eles estão sendo referenciados.

    Leonardo Lourenço Silva


    segunda-feira, 30 de setembro de 2013 19:14
  • Boa tarde Leonardo,

    Os arquivos css estão todos lá, e estão todos referenciados no BundleConfig. 

    segunda-feira, 30 de setembro de 2013 19:28
  • Boa tarde Leonardo,

    Os arquivos css estão todos lá, e estão todos referenciados no BundleConfig. 

    Olhando o código fonte da página, em modo de execução ele te mostra os CSS agrupados ?

    Monitore a página, aperte F12 e vá na aba NetWork (CHROME), e navega na página na página, verifique se ele baixa o arquivo CSS...


    Leonardo Lourenço Silva


    segunda-feira, 30 de setembro de 2013 19:34
  • Eu verifiquei na minha aplicação, no local ele carrega 4 arquivos CSS, já no servidor 2, mas não consigo saber quais são, porque os nomes estão criptografados.
    segunda-feira, 30 de setembro de 2013 19:43
  • Retire o jquery.js e o jquery.mobile.js do bundle.

    Tive o mesmo problema em uma aplicação mobile.

    Aparentemente quando se une todos os js em um único arquivo o mobileinit do jquery mobile para de funcionar.

    segunda-feira, 30 de setembro de 2013 21:32
    Moderador
  • Joao_Prado,

    Eu retirei as js do bundle, mas com isso nem no local ela pegou o CSS.

    Parece que falta refereciar alguma coisa, mas não sei o que.

    segunda-feira, 30 de setembro de 2013 21:57