none
Erro ao acessar DLL RRS feed

  • Pergunta

  • Opa pessoal, tenho o seguinte ambiente:

    - Projeto ClassLibrary C# com diversas classes, uma delas é ClientePJ.

    - ConsoleApplication que lê essa classe e utiliza os métodos dela.

    O problema:

    Eu adiciono nas referencias do ConsoleApplication a .dll gerada pelo projeto ClassLibrary. A primeiro momento, parece funcionar, os erros que apareciam grifados já não aparece e eu posso navegar pelo ObjectBrowser normalmente nas classes que estão nessa biblioteca que adicionei.

    Assim que eu clico em "build" tudo que esta relacionado a biblioteca que eu adicionei fica grifado e aparecem mensagens de erro dizendo que devo adicionar a referencia.

    Ela está lá, a primeiro momento tudo é acessivel, somente quando executo esse consoleApplication que consumiria a dll que não funciona.

    O que estou esquecendo?

    Att.

    terça-feira, 11 de setembro de 2012 13:43

Respostas

  • Lucas,

    Eu tive um problema parecido e resolvi da seguinte forma

     - Clique com o botão direito em cima do projeto que esta perdendo a referência

     - Clique em propriedades e mude o valor do Target framework

    depois é só salvar, dar um Clean e compilar novamente

    Comigo isso funcionou


    Bruno Viegas D. Ribeiro

    Nunca abandone sua thread!
    - Se alguma resposta resolveu seu problema marque-a como resposta para que possa ajudar outras pessoas.
    - Se a resposta não resolveu, mas ajudou a você chegar a sua resposta Marque-a como útil.

    • Marcado como Resposta LucasSchoch terça-feira, 11 de setembro de 2012 14:06
    terça-feira, 11 de setembro de 2012 14:02

Todas as Respostas

  • a principio não está esquecendo nada... cola o erro ai pra nós vermos....
    terça-feira, 11 de setembro de 2012 13:50
  • Error 24 The type or namespace name 'Cadastro' could not be found (are you missing a using directive or an assembly reference?) C:\Users\lucas.schoch\Documents\Visual Studio 2010\Projects\Cadastro\ConsoleApplication1\Program.cs 5 7 ConsoleApplication1

    Porém está lá.

    Existe alguma coisa no meu código do ClassLibrary(Cadastro) que pode causar esse problema?

    terça-feira, 11 de setembro de 2012 13:58
  • Lucas,

    Eu tive um problema parecido e resolvi da seguinte forma

     - Clique com o botão direito em cima do projeto que esta perdendo a referência

     - Clique em propriedades e mude o valor do Target framework

    depois é só salvar, dar um Clean e compilar novamente

    Comigo isso funcionou


    Bruno Viegas D. Ribeiro

    Nunca abandone sua thread!
    - Se alguma resposta resolveu seu problema marque-a como resposta para que possa ajudar outras pessoas.
    - Se a resposta não resolveu, mas ajudou a você chegar a sua resposta Marque-a como útil.

    • Marcado como Resposta LucasSchoch terça-feira, 11 de setembro de 2012 14:06
    terça-feira, 11 de setembro de 2012 14:02
  • Mudar o Target framework do ClassLibrary? Para qual?

    Isso não implica em alterações manuais?

    terça-feira, 11 de setembro de 2012 14:05
  • Meu, funcionou mesmo, valeu !

    terça-feira, 11 de setembro de 2012 14:06