none
Há problemas críticos ao atualizar a .net framework de um servidor? RRS feed

  • Pergunta

  • Tenho aplicativos em um servidor rodando sob a .net framework 2.0 e agora preciso atualizar para a 4.0 para um novo aplicativo. Quais problemas posso encontrar com essa atualização em relação aos aplicatios antigos?
    segunda-feira, 12 de dezembro de 2011 13:28

Todas as Respostas

  • Vinícius,

    Aqui na empres já migramos vários sistema de 2.0 para 4.0 sem problemas, mas se você utiliza componentes de terceiros, certifique-se de que ele suporta o .Net 4.0 antes da migração.

    []s,


    Carlos dos Santos
    blog: www.carloscds.net 
    twitter: @cdssoftware

    • Sugerido como Resposta hamiltonj terça-feira, 13 de dezembro de 2011 11:39
    segunda-feira, 12 de dezembro de 2011 13:59
  • Caso contenha componentes de terceiros, qual seria os problemas que eu poderia encontrar? (para já investigá-los)
    segunda-feira, 12 de dezembro de 2011 14:37
  • Componente de terceiros você provavelmente não terá o código fonte, então não terá como migrar, se você tirar a framework 2.0 e os componentes foram compilados nela, eles irão parar de funcionar.

    para as aplicações que você tem o código fonte, basta abrir o vs2010 para que ele faça a migração para a framework mais nova e então republica-los.


    Olavo Oliveira Neto
    http://olavooneto.wordpress.com
    Twitter @Olavooneto
    Se for útil marque como resposta e faça um Developer feliz :)
    segunda-feira, 12 de dezembro de 2011 15:17
    Moderador
  • Vinicius,

    Eu tive problemas com o DevExpress, pois ele mudaram o jeito de criar o relatório de uma versão para outra, mas nada que não possa ser resolvido. Como eu disse, o ideal é entrar em contato com o fornecedor e ver se eles suportam o .Net 4.0.

    []s,


    Carlos dos Santos
    blog: www.carloscds.net 
    twitter: @cdssoftware

    segunda-feira, 12 de dezembro de 2011 15:23
  • Era isso que eu temia...

    Olavo, mesmo se deixar instalado ambas frameworks a 2.0 será ignorada? Ou se tiver ambas instaladas, os aplicativos que trabalham com a 4.0 irão funcionar, e os que trabalham com a 2.0 também irão funcionar?

    Desde já, agradeço a respostas de todos. 

    segunda-feira, 12 de dezembro de 2011 16:43
  • Vinícius,

    As aplicações com frameworks diferentes coexistem sem problema, ou seja, se você compilar no .Net 4.0 irá utilizar o framework 4 e se mantiver no 2.0 irá usar o framework 2. Mas você pode instalar todas as versões no seu computador sem problema.

    []s,


    Carlos dos Santos
    blog: www.carloscds.net 
    twitter: @cdssoftware

    • Sugerido como Resposta hamiltonj terça-feira, 13 de dezembro de 2011 11:39
    segunda-feira, 12 de dezembro de 2011 17:21