none
Copia de dados de uma base para outra RRS feed

  • Pergunta

  • Fiz a importação dos dados usando o assistente, como sempre fiz, aquele que clica com o botão direito em cima da base Tasks / Import Data.

    Os dados vão para a tabela de destino e perdem os caracteres de acentuação, exemplo: São Paulo vai como SÒo Paulo.

    Porque isso ocorre?

    terça-feira, 17 de fevereiro de 2015 00:27

Respostas

  • CEFL,
    Vou marcar minha resposta para a thread ok? Se você ainda estiver com problemas, desmarque a resposta e nos retorne respondendo as dúvidas para facilitar o nosso entendimento e podermos ajuda-lo.

    Obrigado,
    Abraço!


    Eduardo Romero

    Esse conteudo e fornecido sem garantias de qualquer tipo, seja expressa ou implicita.

    MSDN Community Support

    Por favor, lembre-se de Marcar como Resposta as respostas que resolveram o seu problema. Essa e uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais facil para os outros visitantes encontrarem a resolucao mais tarde.

    quinta-feira, 19 de fevereiro de 2015 19:48

Todas as Respostas

  • Bom dia CEFL,

    Isso ocorre porque os COLLATIONS das suas bases de origem e destino estão diferentes. Um deles com certeza é accent sensitive e o outro não é por isso as palavras com acento ficam da maneira que você está vendo.


    Mariana Del Nero /* Se a resposta foi útil, não esqueça de marcá-la */

    quarta-feira, 18 de fevereiro de 2015 11:15
  • o collation é o mesmo CI_AI, mas isso acontece somente na transferência de dados entre as bases, as aplicações gravam de forma normal.
    quarta-feira, 18 de fevereiro de 2015 12:16
  • CEFL,

    O Collation é o mesmo entre as duas bases?

    Por acaso esta ativado alguma configuração Set_Ansi_Null ou Set_Quoted_Identifier?


    Pedro Antonio Galvao Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | Professor Universitario | SoroCodigos | @JuniorGalvaoMVP | http://pedrogalvaojunior.wordpress.com]

    • Sugerido como Resposta Eduardo.Romero quinta-feira, 19 de fevereiro de 2015 11:08
    • Não Sugerido como Resposta Eduardo.Romero quinta-feira, 19 de fevereiro de 2015 19:47
    quarta-feira, 18 de fevereiro de 2015 14:44
  • Bom dia CEFL,

    Alguma novidade do caso? Conseguiu fazer funcionar? Nos retorne com mais detalhes.

    Obrigado,

    Abraço!


    Eduardo Romero

    Esse conteudo e fornecido sem garantias de qualquer tipo, seja expressa ou implicita.

    MSDN Community Support

    Por favor, lembre-se de Marcar como Resposta as respostas que resolveram o seu problema. Essa e uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais facil para os outros visitantes encontrarem a resolucao mais tarde.

    • Sugerido como Resposta Eduardo.Romero quinta-feira, 19 de fevereiro de 2015 19:47
    quinta-feira, 19 de fevereiro de 2015 11:09
  • CEFL,
    Vou marcar minha resposta para a thread ok? Se você ainda estiver com problemas, desmarque a resposta e nos retorne respondendo as dúvidas para facilitar o nosso entendimento e podermos ajuda-lo.

    Obrigado,
    Abraço!


    Eduardo Romero

    Esse conteudo e fornecido sem garantias de qualquer tipo, seja expressa ou implicita.

    MSDN Community Support

    Por favor, lembre-se de Marcar como Resposta as respostas que resolveram o seu problema. Essa e uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais facil para os outros visitantes encontrarem a resolucao mais tarde.

    quinta-feira, 19 de fevereiro de 2015 19:48