none
Envio de E-mail (sp_send_dbmail) RRS feed

  • Pergunta

  •  Boa tarde!

     Estou tentando enviar e-mails utilizando a

    sp_send_dbmail, mas a mesma nao funciona. Detalhe. Este serviço vinha funcionando normalmente até a ultima semana.

    segunda-feira, 8 de novembro de 2010 16:28

Todas as Respostas

  • Ariston,

    Você já consultou o log de eventos do SQL Server e do Windows para tentar identificar se ocorreu alguma mudança?


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário | MSIT.com]
    quinta-feira, 11 de novembro de 2010 12:38
  • Ariston,

    Qual é a mensagem de erro que você esta recebendo durante a tentativa de utilização da sp_send_dbmail?


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário | MSIT.com]
    quinta-feira, 11 de novembro de 2010 12:39
  • Olá, como você disse que isto estava funcionando anteriormente,

    pode ser que o serviço SQL Server Agent esteja parado no Servidor (Painel de Controle / Ferramentas Administrativo / Serviços) ou as configurações de SMTP do mesmo foram perdidas ou alteradas incorretamente.

    São possibilidades reais, assim mesmo, seria interessante que você detalhasse o erro para que possamos ter maior noção a respeito do problema.

    O link abaixo mosta como configurar e resolver erros no SQL Server Agent Mail:

    http://classicasp.aspfaq.com/email/how-do-i-send-e-mail-from-sql-server.html

     


    Se o post foi útil marque como resposta. - Advanced Web Application - MCP - Twitter: @mpghelli
    sexta-feira, 12 de novembro de 2010 17:11
  • Ariston,

    O servidor de e-mail que você utiliza esta dentro da sua empresa ou hospedado fora?


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário | MSIT.com]
    segunda-feira, 22 de novembro de 2010 17:42
  • Olá,

    Caso seu problema tenha sido resolvido, favor marcar como resposta os posts que lhe ajudaram a resolver o problema, pois isto facilita aos demais usuários do forúm a encontrarem as informações procuradas.

    Caso ainda o problema ainda não tenha sido resolvido, você pode identificar o que não está dando certo para que possamos respondê-lo?

    Obrigado


    Se o post foi útil marque como resposta. - Advanced Web Application - MCP - Twitter: @mpghelli
    quinta-feira, 25 de novembro de 2010 16:23
  • Olá!

     Primeiramente obrigado pelos retornos... Mas infelizmente o problema nao foi solucionado.

    Acontece exporaticamente. E só volta a enviar os e-mails quando dou um restart no SQL SERVER. Não adianta apenas reiniciar o AGENT.

    respondendo a pergunta... O Servidor de email esta fora da empresa. Mas os e-mails estão funcionando normalmente. A única coisa que nao, é o envio via SQL.

    Caso haja algum serviço que possa ser iniciado manualmente para que os e-mail possam ser enviados, tb ajuda bastante.

     

    Obrigado,

    Jr.

    quarta-feira, 12 de janeiro de 2011 18:00
  • Ariston,

    Por acaso não esta ocorrendo algum processo de Deadlock durante a tentativa de envio destes e-mails?


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário | MSIT.com]
    quinta-feira, 13 de janeiro de 2011 21:56
  • Não havia pensado nesta possibilidade.... Mas ela existe! Vou verificar. Uma vez que existe uma query consideravalmente grande antes do envio do e-mail.

     

    Obrigado!

    quarta-feira, 4 de maio de 2011 11:35
  • Pessoal, primeirameite pesso desculpas pela demora na resposta...

    Criei uma saida paleativa para o problema... Criei um job onde faz o stop e start a cada 1 minuto no processo de email

    (exec sysmail_Stop_sp, exec sysmail_Start_sp). Não resolveu o problema definitivamente, mas diminuiu bastante. 

    segunda-feira, 30 de janeiro de 2012 11:37
  • Ariston,

    Nossa realmente é algo bastante fora da realidade!

    Você chegou a verificar as configurações do seu Database Mail para identificar se não existe alguma gerando este tipo de situação.

    Outra possibilidade, seria se alguma aplicação possa estar gerando algum tipo de concorrência com o SQL Server Agent, como também, algum outro job pode estar derrubando o seu SQL Server Agent.


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário | MSIT.com]
    quarta-feira, 1 de fevereiro de 2012 23:22
  • Oi Junior... esse problema ficou para história... Mudei a versão do SQL para r2, e o mesmo nunca mais aconteceu... "Vai saber"...rs.

    Valeu pela força!

    Jr.

    sexta-feira, 15 de junho de 2012 11:42