locked
SOMASE MATRIZ OU SOMARPRODUTO... AJUDA RRS feed

  • Pergunta

  • Amigos,
    Tenho um banco de dados com vários clientes, tipo de produtos, preço médio, Faturamento e peso (Kg).
    Preciso consolidar por cliente, as informações totais de venda por produto e peso (Kg)
    Exemplo de Fórmula que usei... mas não da certo...

    PAINEL DE BUSCA:

    CRITÉRIOS

    CLIENTE 2138477 2138467 2093759
    2116551 2116554 2116554
    CRITÉRIOS VOL.    
    CAFÉ  fórmula
    CAPPUCCINO  
    SOLÚVEL  
    FILTRO      

    Fórmula: =somarproduto(c$1$:c$1000$=2138777)*(c$1$:c$1000$=2138467)*(c$1$:c$1000$=2116554)*(B$1$:B$1000$=cafe)*(E$1$:E$1000$)))))

    OU UMA fórmula SOMASE COM MATRIZ... mas num sei como fazer...


    BANCO DE DADOS:
    A                 B                    C               D              E             F            G        H

    COD FAMILIA CLIENTE TP CONVERSÃO VALOR PREÇO FAT
    10031082 CAFES 2116554 KG                0,25 -4,50 8,20 -36,9
    10031090 CAFES 2116554 KG                0,50 -1,00 8,20 -8,2
    10032602 SOLUVEIS 2116554 UN                0,05 -0,10 23,60 -2,4
    10032603 SOLUVEIS 2116555 UN                1,05 -0,10 23,60 -2,4
    12031007 CAFES 2138487 KG                0,50 4375,00 8,20 35.875,0
    12031010 CAFES 2138487 KG                0,50 8300,00 8,20 68.060,0
    12031021 CAFES 2138487 KG                0,50 835,00 8,40 7.014,0

    terça-feira, 16 de março de 2010 23:45

Todas as Respostas

  • Observei alguns erros em relação à fórmula postada:
    1. O posicionamento dos cifrões deve anteceder a letra e o número da célula referenciada. Desta forma, escreve-se $C$1 e não C$1$
    2. Ao utilizar comparações com textos, deve-se colocá-los entre aspas. Desta forma o correto é ($B$1:$B$1000="CAFES").
    3. As comparações realizadas com as células da coluna C devem ser somadas e não multiplicadas, pois não ocorrem simultaneamente.
    Feitas estas observações, a sintaxe da fórmula será:
    =SOMARPRODUTO((($C$1:$C$1000=2138777)+($C$1:$C$1000=2138467)+($C$1:$C$1000=2116554))*($B$1:$B$1000="CAFES")*($E$1:$E$1000))
    [ ]S

    Adilson Soledade - MOS http://adilsonsoledade.blogspot.com/
    • Sugerido como Resposta adilsonsoledade quarta-feira, 17 de março de 2010 00:37
    quarta-feira, 17 de março de 2010 00:36
  • Boa Noite Adilson,
    Amigo não deu certo.. socorro...
    A fórmula da um erro de NUM#, detalhe, as informações de valor (na coluna E) podem ser negativas, será que por isso da erro?
    Usei dai uma fórmula de soma(se){} matriz, mas as vezes preciso somar até 7 códigos de clientes dai a fórmula fica grande demais e não soma... segue fórmula como faço:

    {soma(se(BANCO_DADOS.xls]VENDA AS'!$D$12:$D$1000=$H$186;se(BANCO_DADOS.xls]VENDA AS'!$C$12:$C$1000=$B191);'[BANCO_DADOS.xls]VENDA AS'!$G$12:$G$1000)))+soma(se(BANCO_DADOS.xls]VENDA AS'!$D$12:$D$1000=$I$186;se(BANCO_DADOS.xls]VENDA AS'!$C$12:$C$1000=$B191);'[BANCO_DADOS.xls]VENDA AS'!$G$12:$G$1000)))}

    ou somar produto, mas da erro...

    =SOMARPRODUTO((('[BANCO_DADOS.xls]VENDA AS'!$D$12:$D$1000=$H$186)+('[BANCO_DADOS.xls]VENDA AS'!$D$12:$D$1000=$I$186))*('[BANCO_DADOS.xls]VENDA AS'!$C$12:$C$1000=$B191)*('[BANCO_DADOS.xls]VENDA AS'!$G$12:$G$1000))

    colunas
         B                      C                            D                       E                                                  

    COD

    FAMILIA

    CÓD. CLIENTE

    UMB

    CONVERSÃO

    VALOR CONVERTIDO

    PM

    ROB

    12031007

    CAFES

    2138487

    KG

                            0,50

    1990,00

    8,20

    16.318,0

    12031010

    CAFES

    2138487

    KG

                            0,50

    2515,00

    8,20

    20.623,0

    12031025

    CAFES

    2138487

    KG

                            0,50

    145,00

    8,20

    1.189,0

    12031031

    CAFES

    2138487

    KG

                            0,50

    450,00

    8,20

    3.690,0

    12034000

    CAPPUCCINO

    2138487

    KG

                             1,00

    8,00

    22,00

    176,0

    12034003

    CAPPUCCINO

    2138487

    CX

                              1,00

    1,00

    32,50

    32,5

    12034007

    CAPPUCCINO

    2138487

    UN

                              0,20

    86,40

    16,70

    1.442,9

    12034008

    CAPPUCCINO

    2138487

    UN

                              0,40

    62,40

    13,23

    825,2

    12034010

    CAPPUCCINO

    2138487

    CX

                              1,00

    5,00

    22,00

    110,0

    12034017

    CAPPUCCINO

    2138487

    UN

                              0,15

    28,80

    25,33

    729,6

    12031005

    CAFES

    2138487

    KG

                              0,25

    5,00

    8,20

    41,0

    12034022

    CAPPUCCINO

    2138487

    UN

                              0,20

    14,40

    quarta-feira, 17 de março de 2010 23:34
  • Você consegue postar o arquivo?

    [ ]s


    Adilson Soledade - MOS http://adilsonsoledade.blogspot.com/
    • Sugerido como Resposta JOSEPH RENATO domingo, 9 de maio de 2010 18:01
    sexta-feira, 19 de março de 2010 02:04
  • http://www.4shared.com/file/247150308/b4dfd25c/SOMAR_PRODUTO.html
    Coloquei o arquivo neste link, me ajude meu amigo.
    terça-feira, 23 de março de 2010 00:54