none
Problema de versão RRS feed

  • Pergunta

  • Galera estou com um problema na publicação do meu projeto.. 

    pois o projeto foi feito em .NET 2.0 e agora estou atualizando o proprio no VS 2010,

    sendo que quando publico ele da um erro de versão nos componentes web....

    diz que a versão é 4.0 e não está implementada no projeto....

     

    o erro vem aqui:

    essa é minha Dll

    System.Web.Extensions, Version=1.0.61025.0

    e ela diz que está dando pau pois a versão 4.0 não foi encontrada...

    ambiente:

    ASP.NET

    VB.NET

    .NET 2.0

    alguém sabe como posso resolver???

    pois quando compilo fica lega.... mas quando publico ele da pau...

    terça-feira, 31 de janeiro de 2012 16:51

Respostas

  • Faz o seguinte... verifiquei se ela está na pasta References... provavelmente vai estar, mas pode ser a versão antiga... Clique com o direito na pastinha references, Add Reference, no .NET espera carregar a lista, depois que carregar clique na primeira coluna para ordenar e assim aparece todos os registros, depois procure o System.Web.Extensions version 4.x.x.x e clique em add. Tente dar o publish novamente.
    Ao infinito e além!
    • Editado Fabio R. Luz terça-feira, 31 de janeiro de 2012 17:09
    • Marcado como Resposta Márcio Abrantes sexta-feira, 3 de fevereiro de 2012 12:17
    terça-feira, 31 de janeiro de 2012 17:09
  • é a DLL está com a versão antiga, porem nem acho ela na add referencia, nem a antiga, nem a nova...
    • Marcado como Resposta Márcio Abrantes sexta-feira, 3 de fevereiro de 2012 12:17
    terça-feira, 31 de janeiro de 2012 17:17
  • Faça o que eu disse lá em cima, espera a lista carregar, depois clique na primeira coluna "Component Name" (Certifique-se de aparecer a setinha do lado do nome) para ordenar, depois que você fizer isso vai aparecer todas as opções. Aí você procura ...
    Ao infinito e além!
    • Editado Fabio R. Luz terça-feira, 31 de janeiro de 2012 17:27
    • Marcado como Resposta Márcio Abrantes sexta-feira, 3 de fevereiro de 2012 12:17
    terça-feira, 31 de janeiro de 2012 17:27
  • sim pow, isso mesmo, sendo que não aparece ela.... as únicas que aparecem com System.Web é as:

    System.Web

    System.Web.Mobile

    System.Web.RegularExpressions

    System.Web.Services..

    é as únicas com Web

    • Marcado como Resposta Márcio Abrantes sexta-feira, 3 de fevereiro de 2012 12:17
    terça-feira, 31 de janeiro de 2012 18:02
  • Tem certeza que você clicou em component name ?? para mim aparece normal olha:

     

    Bom tente novamente, na pior das hipóteses upo a minha em um file hoster

    Faça o download http://sharex.xpg.com.br/files/6124302385/System.Web.Extensions.rar.html, vá em add reference > browse e selecione-o

     


    Ao infinito e além!
    • Editado Fabio R. Luz terça-feira, 31 de janeiro de 2012 19:13
    • Marcado como Resposta Márcio Abrantes sexta-feira, 3 de fevereiro de 2012 12:17
    terça-feira, 31 de janeiro de 2012 19:07
  • Sim sim, no meu não aparece, mas mesmo assim quando compilo ele roda legal... só quando eu publico que ele dá pau, e a dll do link seria a 4.0, e ainda estou a fazer com a 2.0, ainda não posso migrala.. :/
    • Marcado como Resposta Márcio Abrantes sexta-feira, 3 de fevereiro de 2012 12:17
    quarta-feira, 1 de fevereiro de 2012 12:49
  • Aaaa então você quer continuar com a 2.0 ? Então vai no solution explorer, clica com o direito no seu projeto, vai em properties, na aba application em target framework selecione o framework 2.0
    Ao infinito e além!
    • Marcado como Resposta Márcio Abrantes sexta-feira, 3 de fevereiro de 2012 12:17
    quarta-feira, 1 de fevereiro de 2012 18:56
  • Tenta remover essa chave do web config:  System.Web.Extensions, Version=1.0.61025.0
    • Marcado como Resposta Márcio Abrantes sexta-feira, 3 de fevereiro de 2012 12:17
    quinta-feira, 2 de fevereiro de 2012 19:23
  • é ainda tem algumas publicações que tenho que postar antes de migra... pois pra migrar um projeto de 2003 ~~ 2004... vai ser tenso :)

    mas tudo bem já resolvido...

    valeu ai pela ajuda...

     

     

    minha solução foi instalar o ASPAJAXExtSetup.msi, ai sim consegui visualizar essas DLLs.

    obrigado mesmo :)

    ainda vou precisar muito daqui pra migração... pois sou programador novata na plataforma .NET e nunca vi VB, só programo em C#...

    qualquer coisa quem curtir windows phone, curti a pagina lá no face

    www.facebook.com/wp7pe

    • Marcado como Resposta Márcio Abrantes sexta-feira, 3 de fevereiro de 2012 12:16
    sexta-feira, 3 de fevereiro de 2012 12:16

Todas as Respostas

  • Faz o seguinte... verifiquei se ela está na pasta References... provavelmente vai estar, mas pode ser a versão antiga... Clique com o direito na pastinha references, Add Reference, no .NET espera carregar a lista, depois que carregar clique na primeira coluna para ordenar e assim aparece todos os registros, depois procure o System.Web.Extensions version 4.x.x.x e clique em add. Tente dar o publish novamente.
    Ao infinito e além!
    • Editado Fabio R. Luz terça-feira, 31 de janeiro de 2012 17:09
    • Marcado como Resposta Márcio Abrantes sexta-feira, 3 de fevereiro de 2012 12:17
    terça-feira, 31 de janeiro de 2012 17:09
  • é a DLL está com a versão antiga, porem nem acho ela na add referencia, nem a antiga, nem a nova...
    • Marcado como Resposta Márcio Abrantes sexta-feira, 3 de fevereiro de 2012 12:17
    terça-feira, 31 de janeiro de 2012 17:17
  • Faça o que eu disse lá em cima, espera a lista carregar, depois clique na primeira coluna "Component Name" (Certifique-se de aparecer a setinha do lado do nome) para ordenar, depois que você fizer isso vai aparecer todas as opções. Aí você procura ...
    Ao infinito e além!
    • Editado Fabio R. Luz terça-feira, 31 de janeiro de 2012 17:27
    • Marcado como Resposta Márcio Abrantes sexta-feira, 3 de fevereiro de 2012 12:17
    terça-feira, 31 de janeiro de 2012 17:27
  • sim pow, isso mesmo, sendo que não aparece ela.... as únicas que aparecem com System.Web é as:

    System.Web

    System.Web.Mobile

    System.Web.RegularExpressions

    System.Web.Services..

    é as únicas com Web

    • Marcado como Resposta Márcio Abrantes sexta-feira, 3 de fevereiro de 2012 12:17
    terça-feira, 31 de janeiro de 2012 18:02
  • Tem certeza que você clicou em component name ?? para mim aparece normal olha:

     

    Bom tente novamente, na pior das hipóteses upo a minha em um file hoster

    Faça o download http://sharex.xpg.com.br/files/6124302385/System.Web.Extensions.rar.html, vá em add reference > browse e selecione-o

     


    Ao infinito e além!
    • Editado Fabio R. Luz terça-feira, 31 de janeiro de 2012 19:13
    • Marcado como Resposta Márcio Abrantes sexta-feira, 3 de fevereiro de 2012 12:17
    terça-feira, 31 de janeiro de 2012 19:07
  • Sim sim, no meu não aparece, mas mesmo assim quando compilo ele roda legal... só quando eu publico que ele dá pau, e a dll do link seria a 4.0, e ainda estou a fazer com a 2.0, ainda não posso migrala.. :/
    • Marcado como Resposta Márcio Abrantes sexta-feira, 3 de fevereiro de 2012 12:17
    quarta-feira, 1 de fevereiro de 2012 12:49
  • Aaaa então você quer continuar com a 2.0 ? Então vai no solution explorer, clica com o direito no seu projeto, vai em properties, na aba application em target framework selecione o framework 2.0
    Ao infinito e além!
    • Marcado como Resposta Márcio Abrantes sexta-feira, 3 de fevereiro de 2012 12:17
    quarta-feira, 1 de fevereiro de 2012 18:56
  • Tenta remover essa chave do web config:  System.Web.Extensions, Version=1.0.61025.0
    • Marcado como Resposta Márcio Abrantes sexta-feira, 3 de fevereiro de 2012 12:17
    quinta-feira, 2 de fevereiro de 2012 19:23
  • é ainda tem algumas publicações que tenho que postar antes de migra... pois pra migrar um projeto de 2003 ~~ 2004... vai ser tenso :)

    mas tudo bem já resolvido...

    valeu ai pela ajuda...

     

     

    minha solução foi instalar o ASPAJAXExtSetup.msi, ai sim consegui visualizar essas DLLs.

    obrigado mesmo :)

    ainda vou precisar muito daqui pra migração... pois sou programador novata na plataforma .NET e nunca vi VB, só programo em C#...

    qualquer coisa quem curtir windows phone, curti a pagina lá no face

    www.facebook.com/wp7pe

    • Marcado como Resposta Márcio Abrantes sexta-feira, 3 de fevereiro de 2012 12:16
    sexta-feira, 3 de fevereiro de 2012 12:16