none
Perdi a Base de Dados OLAP, como implantar novamente? RRS feed

  • Pergunta

  • Boa tarde a todos,

    Na empresa onde trabalho, divemos um problemão com os discos storage, perdemos o banco de dados do Analysis Services (o que fica dentro de DataBases do Analysis Service, dimensões, cubos e etc...).

    Recuperamos o banco de dados Datawarehouse da instância SQL Server que era a fonte de dados do mesmo. Está com o mesmo nome/local etc.

    Mas não consigo mais processar o projeto (Deploy/Process)... informa erro "". (sem descrição). ou erro informando não encontrar as dimensões...

    Como posso re-implantar a base no Analysis apartir da base DW disponível? Há alguma forma? Ou tenho de refazer tudo?


    Obrigado e atenciosamente,
    Rafael
    quarta-feira, 8 de julho de 2009 19:23

Respostas

  • Rafael, 

    Acredito que o sua base OLAP acabou corrompendo a solução mais indicada é pegar o arquivo de solução e dar um deploy em todo o projeto. 

    Principal problema será reprocessar as tabelas fatos, indico rodar as dimensões depois rodas as fatos por partições da mais atual até a mais antiga assim deixa a base pronta para consultas mais atuais. 

    Abraços. 

    Diogo A. Di Pietro
    • Marcado como Resposta rafael.dev quinta-feira, 20 de agosto de 2009 13:35
    terça-feira, 11 de agosto de 2009 18:02
  • Rafael,


    Concordo com a sugestão do Diego.

    Executando novamente o deploy do projeto, todo projeto será reconstruindo, refazendo toda estrutura de acesso e integridade dos componentes de conexão.


    Pedro Antonio Galvão Junior - MVP - Windows Server System - SQL Server/Coordenador de Projetos/DBA
    • Marcado como Resposta rafael.dev quinta-feira, 20 de agosto de 2009 13:35
    quarta-feira, 12 de agosto de 2009 03:30

Todas as Respostas

  • Rafael, 

    Acredito que o sua base OLAP acabou corrompendo a solução mais indicada é pegar o arquivo de solução e dar um deploy em todo o projeto. 

    Principal problema será reprocessar as tabelas fatos, indico rodar as dimensões depois rodas as fatos por partições da mais atual até a mais antiga assim deixa a base pronta para consultas mais atuais. 

    Abraços. 

    Diogo A. Di Pietro
    • Marcado como Resposta rafael.dev quinta-feira, 20 de agosto de 2009 13:35
    terça-feira, 11 de agosto de 2009 18:02
  • Rafael,


    Concordo com a sugestão do Diego.

    Executando novamente o deploy do projeto, todo projeto será reconstruindo, refazendo toda estrutura de acesso e integridade dos componentes de conexão.


    Pedro Antonio Galvão Junior - MVP - Windows Server System - SQL Server/Coordenador de Projetos/DBA
    • Marcado como Resposta rafael.dev quinta-feira, 20 de agosto de 2009 13:35
    quarta-feira, 12 de agosto de 2009 03:30
  • Diogo / Junior,

    Obrigado, depois de debater com a cabeça em dezenas de tentativas onde o erro para "DEPLOY ALL / PROCESS ALL" era exibido apenas um ponto " . "

    Descobri que era os Roles que estavam dando problema na implantação/processamento, simplesmente não deixava, deletei o objeto de regras e consegui, ficou certo com o Deploy do projeto.


    Rafael

    quinta-feira, 20 de agosto de 2009 13:35