none
MVC + Oracle RRS feed

  • Pergunta

  • Pessoal bom dia.

    Estou com um certo problema. Eu publiquei minha aplicação. Configurei meu IIS e subi para meu IIS local.

    Eu tive que baixar o ODP.net da Oracle para ter acesso a dados (Estou usando entityframework). No IIS local está OK.

    Subi para o servidor de desenvolvimento e tive alguns problemas. Resolvi todos mas estou com um muito difícil. Eu instalei o provider da Oracle no servidor e subi o TNS também. Minha ideia é que o TNS está em um um caminho na minha máquina e no servidor está em outro, quando compilado gera o problema.

    Segue Imagem.

    Há alguma forma no Web.config de passar o caminho de forma manual?

    Alguma sugestão??

    segunda-feira, 23 de fevereiro de 2015 13:00

Todas as Respostas

  • Luiz,

    Não parece ser erro de TNS. Mas para verificar se o TNS está ok, execute o comando abaixo no prompt de comando:

    tnsping [NOME_INSTANCIA]

    O ODAC da sua máquina está com a mesma versão do servidor? 

    O servidor é 64bits?


    Carlos Eduardo Ferreira

    segunda-feira, 23 de fevereiro de 2015 16:46
  • Carlo primeiramente muito obrigado pela atenção.

    Então esta tudo ok.

    segunda-feira, 23 de fevereiro de 2015 19:36
  • Fica difícil sem conhecer o ambiente, mas dê uma olhada nesse artigo: http://willon.wikicode.com.br/2012/01/o-provedor-subjacente-falhou-em-open.html


    Carlos Eduardo Ferreira

    segunda-feira, 23 de fevereiro de 2015 20:07
  • Conseguiu resolver seu problema?

    Se sim, feche seu thread, por favor.

    Carlos Eduardo Ferreira

    terça-feira, 9 de junho de 2015 17:45