none
Erro de conexão SQL + Visual Studio (C#) RRS feed

  • Pergunta

  • Acontece que tenho o seguinte erro quando tento fazer a conexão do banco com o sistema.

    Erro: "Erro de rede ou específico à instância ao estabelecer conexão com o SQL Server. O servidor não foi encontrado ou não estava acessível. Verifique se o nome da instância está correto e se o SQL Server está configurado para permitir conexões remotas."

    o que fazer quando acontece este erro por favor me ajudem !!!

    segunda-feira, 22 de fevereiro de 2016 01:37

Respostas

  • Tente conectar utilizando o Server Explorer do Visual Studio, se conectar lá, o problema está no teu código (então tu vai precisar nos mostrar teu código).

    Caso não dê certo nem no Server Explorer, a string de conexão está realmente errada.

    O conexão padrão seria "JUNIOR-PC\SQLEXPRESS", tu tens certeza que alterou ela?


    Att., Rafael Simor


    • Marcado como Resposta JuniorTunjr segunda-feira, 22 de fevereiro de 2016 04:28
    • Editado SimorC segunda-feira, 21 de março de 2016 15:06 Team Explorer > Server Explorer
    segunda-feira, 22 de fevereiro de 2016 02:23

Todas as Respostas

  • Boa noite.

    Normalmente este erro é por causa da string de configuração errada (pode ser que o servidor não esteja configurado corretamente, mas normalmente não chega a isso).

    Verifique se tua string de conexão está correta (servidor, usuário, senha, etc.).


    Att., Rafael Simor

    segunda-feira, 22 de fevereiro de 2016 02:09
  • Em relação a string eu fiz o seguinte, conectei o visual studio com o meu banco usando as ferramentas e nas opçoes tinha a string que foi a seguinte:

    "Data Source=JUNIOR-PC\SQLSERVERJR;Initial Catalog=Aluno;Integrated Security=True"

    lembrando que meu login é através da autenticação do windows.


    segunda-feira, 22 de fevereiro de 2016 02:13
  • Tente conectar utilizando o Server Explorer do Visual Studio, se conectar lá, o problema está no teu código (então tu vai precisar nos mostrar teu código).

    Caso não dê certo nem no Server Explorer, a string de conexão está realmente errada.

    O conexão padrão seria "JUNIOR-PC\SQLEXPRESS", tu tens certeza que alterou ela?


    Att., Rafael Simor


    • Marcado como Resposta JuniorTunjr segunda-feira, 22 de fevereiro de 2016 04:28
    • Editado SimorC segunda-feira, 21 de março de 2016 15:06 Team Explorer > Server Explorer
    segunda-feira, 22 de fevereiro de 2016 02:23
  • consegui resolver o erro, a string correta era esta "Data Source=JUNIOR-PC\\SQLSERVERJR;Initial Catalog=Aluno;Integrated Security=SSPI"

    tive que usar 2 \\ pois quando usava somente uma dava outro erro dai então procurei em outros sites e consegui corrigir tudo, obrigado Rafael!

    segunda-feira, 22 de fevereiro de 2016 04:28