none
Erro ao utilizar Entity Framework 4 com Sql Azure RRS feed

Respostas

  • Olá a todos.

    O problema do Vinícius foi solucionado por ele mesmo conforme pode ser constatado neste link: http://azureservicesbr.ning.com/group/microsoftsqldataservices/forum/topics/erro-ao-utilizar-entity, abaixo replico a solução dada por ele mesmo.

    Solução encontrada pelo próprio ViníciusMarra:

    "Vinícius Oliveira Marra em 3 novembro 2010 at 0:44

    Boa Noite,

    Se alguem passar por este problema eu consegui resolver!
    É o seguinte.
    O problema é referente ao lazing loading mesmo, que quando utilizando o sql azure acontece o erro.
    O que eu fiz foi desabilitar o lazing loading no meu model.edmx e modificar o meu dao.

    Select antes:

    public override IQueryable Select(Func expression)
    {
    return ObjectContextManager.Instance.GetContext().Pedido.Where(expression).AsQueryable();
    }

    Select modificado para funcionar:

    public override IQueryable Select(Func expression)
    {
    return
    ObjectContextManager.Instance.GetContext().Pedido.
    Include("Cliente").
    Include("Empresa").
    Include("Representante").
    Include("ItemPedido").
    Include("ItemPedido.Produto").
    Where(expression).AsQueryable();
    }

    Eu tive que somente incluir as tabelas relacionas no momento da consulta.

    É isso ai!

    At.

    Vinícius Marra"

    Moderador por gentileza encerrar a Thread e atribuir solução ao ViníciusMarra.

    Abs. e sucesso!

    Lucas A. Romão
    MSN:
    laromao@oxygenhost.com.br
    Blog: http://laromao.wordpress.com/ | Twitter: @LucasRomao
    Líder da Comunidade Azure Services Brasil | Twitter:@AzureServicesBR

    • Marcado como Resposta Daniel Ferreira terça-feira, 21 de junho de 2011 01:12
    quarta-feira, 1 de junho de 2011 19:13
    Proprietário

Todas as Respostas