none
calculo datas excel RRS feed

  • Pergunta

  • tenho duas datas: inicio e fim. exemplo:

    dt inico 15/06/2017
    dt fim 07/07/2017

    olhando as duas datas, preicso saber a quantidade de dias de 01/07 até a data fim 07/07.
    quinta-feira, 10 de agosto de 2017 15:35

Todas as Respostas

  • meu problema na verdade é outro.

    coluna A         coluna B

    15/06/2017     07/07/2017

    preciso verificar qual destas datas está no mês de julho. Depois eu pego a data que está em julho e calculo a diferença em relação a 01/07/2017.

    quinta-feira, 10 de agosto de 2017 16:46
  • Option Explicit
    
    Sub TESTE()
    
    Dim DATAINICIAL As Date
    
    DATAINICIAL = "01/07/2017"
    
    If Month(ThisWorkbook.Sheets("Planilha1").Range("A1")) = 7 Then
    
    MsgBox DateDiff("d", DATAINICIAL, ThisWorkbook.Sheets("Planilha1").Range("A1"))
    
    End If
    
    If Month(ThisWorkbook.Sheets("Planilha1").Range("B1")) = 7 Then
    
    MsgBox DateDiff("d", DATAINICIAL, ThisWorkbook.Sheets("Planilha1").Range("B1"))
    
    End If
    
    End Sub


    Anderson Diniz

    • Sugerido como Resposta AndersonFDiniz2 quinta-feira, 10 de agosto de 2017 17:20
    quinta-feira, 10 de agosto de 2017 17:20
  • Option Explicit
    
    Sub TESTE2()
    
    Dim DATAINICIAL As Date
    
    DATAINICIAL = "01/07/2017"
    
    If Month(ThisWorkbook.Sheets("Planilha1").Range("A1")) = Month(DATAINICIAL) Then
    
    MsgBox DateDiff("d", DATAINICIAL, ThisWorkbook.Sheets("Planilha1").Range("A1"))
    
    End If
    
    If Month(ThisWorkbook.Sheets("Planilha1").Range("B1")) = Month(DATAINICIAL) Then
    
    MsgBox DateDiff("d", DATAINICIAL, ThisWorkbook.Sheets("Planilha1").Range("B1"))
    
    End If
    
    End Sub
    


    Anderson Diniz

    • Sugerido como Resposta AndersonFDiniz2 quinta-feira, 10 de agosto de 2017 17:31
    quinta-feira, 10 de agosto de 2017 17:29
  • Option Explicit
    
    Sub TESTE3()
    
    Dim DATAINICIAL As Date
    
    DATAINICIAL = ThisWorkbook.Sheets("Planilha1").Range("C1")
    
    If Month(ThisWorkbook.Sheets("Planilha1").Range("A1")) = Month(DATAINICIAL) Then
    
    MsgBox DateDiff("d", DATAINICIAL, ThisWorkbook.Sheets("Planilha1").Range("A1"))
    
    End If
    
    If Month(ThisWorkbook.Sheets("Planilha1").Range("B1")) = Month(DATAINICIAL) Then
    
    MsgBox DateDiff("d", DATAINICIAL, ThisWorkbook.Sheets("Planilha1").Range("B1"))
    
    End If
    
    End Sub
    
    
    


    Anderson Diniz

    • Sugerido como Resposta AndersonFDiniz2 quinta-feira, 10 de agosto de 2017 17:31
    quinta-feira, 10 de agosto de 2017 17:31
  • Suponha que uma das datas está na "A2", outra na "B2" e a data de referência, que deve ser comparada, no caso "01/07/17", está na "C2".

    Basta utilizar a fórmula:

    =SE(E(A2-C2<30;A2-C2>0);A2-C2; SE(E(B2-C2<30;B2-C2>0);B2-C2; "Nenhuma das datas está no mês desejado"))

    Abraço.


    Filipe Magno

    sexta-feira, 11 de agosto de 2017 02:00