none
Problema: Conexão com o Banco RRS feed

  • Pergunta

  • Bom dia a todos.

    Utilizo o VS 2005 conectando a diferentes bancos Oracle, SQL Server e SQL Server 2000 e 2005 Express. Até sexta quando foi a ultima vez que trabalhei nisso tava tudo bem, mas hoje quando tento abrir algum desses bancos pelo Server Explorer do meu VS 2005...  ele pede os dados de senha e tudo e roda ele testa a conexão e da resposta como positiva, mas quando tento abrir mesmo, da o seguinte erro:

    Unable to add data connection.

    Chave Inválida para uso no estado especificado.

     

    segunda-feira, 26 de março de 2007 13:28

Respostas

Todas as Respostas

  • Vitor,

    Segundo o post do blog abaixo:

    http://blogs.wdevs.com/sebastien.lachance/archive/2005/11/16/11225.aspx

    ... você deve fechar o VS, apagar o arquivo [SeuProfile]\Application Data\Microsoft\VisualStudio\8.0\ServerExplorer\DefaultView.SEView , e então entrar de novo no Visual Studio.

    Não sei se funciona, mas é exatamente o mesmo problema que você teve.

    Abraços,
    Francisco
    OK, Computer - http://thespoke.net/blogs/fbcjunior/default.aspx

    segunda-feira, 26 de março de 2007 13:42
    Moderador
  • Bom Francisco, se você não sabia se funcionaria essa solução, agora sabemos... funciona sim! valeu a dica, ótima dica!

    abraço!

    segunda-feira, 26 de março de 2007 14:21
  • Olha, perdoe-me minha ignorância, porém não consigo achar este caminho no qual você descreveu:

    [SeuProfile]\Application Data\Microsoft\VisualStudio\8.0\ServerExplorer\DefaultView.SEView...

     

    Onde eu acho esse caminho? Document and Settings, Arquivos de Programas???

    Já procurei em tudo quanto é lugar e não achei nada disso.

    Meu sistema é o Windows XP SP2, e estou tendo exatamente este problema ao tentar acessar o Table Adapter de minha aplicação.

     

    abraços

    quinta-feira, 18 de outubro de 2007 12:25
  •  

    Rento, bom dia!

     

    é no "Documments and settings" mesmo...

    exemplo:

     

    C:\Documents and Settings\vitor\Dados de aplicativos\Microsoft\VisualStudio\8.0\ServerExplorer\DefaultView.SEView...

     

     

    quinta-feira, 18 de outubro de 2007 13:34
  • Show de bola, funcionou aqui tb. Só uma observação. Caso não consigar achar o diretório, é só habilitar para exibir arquivos oculto, pois estas pastas são ocultas... Abraçãooo, valeu pela dica.
    terça-feira, 4 de março de 2008 01:17
  • Ae galera me deem uma força por favor...

    Eu instalei o VS 2008 Express aqui e estou tentando criar um Data Source... quando eu seleciono o banco de dados access aparece "Chave inválida para uso no estado especificado"... já entrei no diretório que vcs falaram apaguei o arquivo mas o problema continua... alguem sabe o que mais pode ser?

    Abraços pra Todos...

    sábado, 22 de março de 2008 14:42
  • Douglas.pos disse:

    Ae galera me deem uma força por favor...

    Eu instalei o VS 2008 Express aqui e estou tentando criar um Data Source... quando eu seleciono o banco de dados access aparece "Chave inválida para uso no estado especificado"... já entrei no diretório que vcs falaram apaguei o arquivo mas o problema continua... alguem sabe o que mais pode ser?

    Abraços pra Todos...



    Idem, tambem tenho uma maquina que acontece esse mesmo problema, trabalho em dois pc com confiuraçoes completamente iguais, em uma maquina roda normal o data source porem a outra não tem como, ja exclui o arquivo mencionado e nada de rodar o Data Source.
    sexta-feira, 6 de março de 2009 16:14
  • tambem estou com esse problema... ou seja... 2 o meu é win vista... e nao achei o arquivo... nem a pasta.... 
    quinta-feira, 12 de março de 2009 00:56
  • tbem to com o mesmo problema.... no win vista
    • Sugerido como Resposta Paulo.gio segunda-feira, 16 de agosto de 2010 12:05
    quinta-feira, 12 de março de 2009 01:06