none
Problemas com a instalação do CRM 4.0 RRS feed

  • Pergunta

  •  

    Estamos tentando instalar o CRM 4.0 (Versão Professional) para teste.

     

    Estamos trabalhando com 2 servidores. Um servidor de SQL e Reporting services  e outro para o CRM. (IIS).

     

    1.       Avisos encontrados durante a instalação, sobre o pacote de idiomas 1046 não encontrado. Já baixamos e instalamos o pacote.

     

         2.       Ao tentar acessar o site, de uma estação da rede, sempre aparece a caixa de diálogo para informar usuário e senha. Mesmo informando     o     usuário crmadmin, recebemos mensagem de acesso não autorizado e o site nem abre.

     

    3.       Digitando o usuário e senha do crmadmin e acessando diretamente da máquina, aparece uma tela azul claro, como se o crm fosse entrar, mas nada acontece. (Dá uma mensagem no rodapé da página, de object expected;

     

     

      

    Já baixamos e atualizamos do sp1 do framework 3.0. Só que nas propriedades do diretório virtual, continua aparecendo como 2. ......Não aparece a opção de 3.0

     
    Alguma dica sobre o que precisa ser ajustado para funcionar?

    Obrigada,

    Elzira

    quarta-feira, 4 de fevereiro de 2009 12:56

Respostas

  • Elzira, seguinte:

    Quanto a opção do Diretorio Virtual nao aparecer a opção 3.0, não se preocupe, as Framework 3.0 e 3.5 são extensões da 2.0, por tanto, nao se preocupe que se ela estive instala(o que você poderá ver na pasta C:\Windows\Microsoft.NET\Framework)

    Quanto ao problema de acesso, o usuário que você criou p/ a conta de serviço, está como adminsitrador do servidor ? as vezes se faz necessário colocar ele com algumas permissões no AD como Enterprise Admin qunado se vai trabalhar com dominios diferentes.

    Verifique como está a permissões dentro de segurança do IIS
    • Marcado como Resposta Elzira domingo, 1 de março de 2009 22:10
    domingo, 8 de fevereiro de 2009 16:44
  • Oi Elzira,

    Já passei pelo problema que você está vivenciando. Isso se refere ao modo de publicação do CRM. Provavelmente suas entradas de DNS endereçam os acessos através da internet, e neste cenário, você deverá utilizar o Microsoft Dynamics CRM IFD Tool.

    Resumindo bem, a função dessa ferramenta é preparar o CRM para trabalhar internamente ou na internet, além de ajustá-lo afim de atender diversos requisitos de cenários como autenticação, certificado digital, etc..

    Publiquei um post no meu blog específico desse tema: http://portaldynamics.wordpress.com/2009/01/16/publicando-dynamics-crm-internet/

    Para maiores informações sobre a ferramenta, acesse: http://www.microsoft.com/downloads/details.aspx?FamilyID=3861e56d-b5ed-4f7f-b2fd-5a53bc71dafc&displaylang=en e para obtê-la, vá em: http://support.microsoft.com/kb/948779

    Por favor nos retorne informando se tudo deu certo.

    []´s

    Amorim
    Carlos Amorim Junior
    • Marcado como Resposta Elzira domingo, 1 de março de 2009 22:10
    quarta-feira, 11 de fevereiro de 2009 12:54
  •  Elzira,

    sei que parece um pouco óbvio, mas já desbloqueou seu firewall ? se instalou com "criar site" a porta padrão é 5555 portanto: http://seuservidor:5555/

    • Marcado como Resposta Elzira domingo, 1 de março de 2009 22:13
    quinta-feira, 19 de fevereiro de 2009 01:06
  • Bom,

    Vejo que o erro que você recebeu no começo da instalação é grave, e tudo indica que o usuário que você usou não tinha as permições correta para instalar o Microsoft CRM.

    Primeiro passo, desinstalar o CRM e instalar novamento, mas agora com o usuário bem configurado.

    OBS, Se você não puder usar o usuário administrador do Domínio, crie um usuário comum e faça o seguinte:

    1) O usuário precisa ser administrador local do Servidor.
    2) Crie uma OU só para o CRM, Delegue o direito para o usuário de criar objetos filhos dentro dessa OU
    3) O usuário precisar ter um login valido no SQL com as seguintes roles de acesso. Setupadmin, Securityadmin, e DBcreator.

    Com isso tudo pronto, pode instalar o CRM novamente. 


    Ronaldo Bernardo MCP - MCTS
    • Marcado como Resposta Elzira domingo, 1 de março de 2009 22:13
    terça-feira, 10 de fevereiro de 2009 19:50
  • Obrigada Olavo. Refizemos a instalação, acertamos as permissões e conseguimos avançar um pouco. O único problema que ainda persiste, é que só consigo me logar diretamente do servidor do CRM. Seguirei as orientações do Carlos Amorin, em relação ao Microsoft Dynamics CRM IFD Tool. 

    Elzira
    • Marcado como Resposta Elzira domingo, 1 de março de 2009 22:12
    quarta-feira, 11 de fevereiro de 2009 17:45
  • Agradeço a todos. Depois de muita briga, conseguimos fazer funcionar ... O documento IFD ajudou bastante.
    • Marcado como Resposta Elzira domingo, 1 de março de 2009 22:12
    domingo, 1 de março de 2009 22:10

Todas as Respostas

  • Olá Elzira,

    Vc ja tentou fazer o seguinte:

    Configure o site  (ex:http://crm) como um site confiavel: No Browser vá até  ferramentas/opções de internet/segurança/sites confiaveis e cadastre o site do CRM como confiavel

    Desabilite tambem o bloqueio de popup do site

    Com essas duas tarefas executadas, já dará para vc avançar na instalação do CRM

    At.

    Antonio Carlos
    acpereira35@hotmail.com


    Antonio Carlos P. Junior
    quarta-feira, 4 de fevereiro de 2009 19:20
  •  Obrigada Antônio Carlos, mas já fizemos isso. Na instalação, recebemos a mensagem de alerta: "Verifique o SPN para a conta usuário do domínio para a Conta Pool de Aplicativos ASP.NET".

    O que significa essa mensagem e pode ser a causa do problema?

    Obrigada,

    Elzira
    quinta-feira, 5 de fevereiro de 2009 17:26
  • Elzira, seguinte:

    Quanto a opção do Diretorio Virtual nao aparecer a opção 3.0, não se preocupe, as Framework 3.0 e 3.5 são extensões da 2.0, por tanto, nao se preocupe que se ela estive instala(o que você poderá ver na pasta C:\Windows\Microsoft.NET\Framework)

    Quanto ao problema de acesso, o usuário que você criou p/ a conta de serviço, está como adminsitrador do servidor ? as vezes se faz necessário colocar ele com algumas permissões no AD como Enterprise Admin qunado se vai trabalhar com dominios diferentes.

    Verifique como está a permissões dentro de segurança do IIS
    • Marcado como Resposta Elzira domingo, 1 de março de 2009 22:10
    domingo, 8 de fevereiro de 2009 16:44
  • Bom,

    Vejo que o erro que você recebeu no começo da instalação é grave, e tudo indica que o usuário que você usou não tinha as permições correta para instalar o Microsoft CRM.

    Primeiro passo, desinstalar o CRM e instalar novamento, mas agora com o usuário bem configurado.

    OBS, Se você não puder usar o usuário administrador do Domínio, crie um usuário comum e faça o seguinte:

    1) O usuário precisa ser administrador local do Servidor.
    2) Crie uma OU só para o CRM, Delegue o direito para o usuário de criar objetos filhos dentro dessa OU
    3) O usuário precisar ter um login valido no SQL com as seguintes roles de acesso. Setupadmin, Securityadmin, e DBcreator.

    Com isso tudo pronto, pode instalar o CRM novamente. 


    Ronaldo Bernardo MCP - MCTS
    • Marcado como Resposta Elzira domingo, 1 de março de 2009 22:13
    terça-feira, 10 de fevereiro de 2009 19:50
  • Oi Elzira,

    Já passei pelo problema que você está vivenciando. Isso se refere ao modo de publicação do CRM. Provavelmente suas entradas de DNS endereçam os acessos através da internet, e neste cenário, você deverá utilizar o Microsoft Dynamics CRM IFD Tool.

    Resumindo bem, a função dessa ferramenta é preparar o CRM para trabalhar internamente ou na internet, além de ajustá-lo afim de atender diversos requisitos de cenários como autenticação, certificado digital, etc..

    Publiquei um post no meu blog específico desse tema: http://portaldynamics.wordpress.com/2009/01/16/publicando-dynamics-crm-internet/

    Para maiores informações sobre a ferramenta, acesse: http://www.microsoft.com/downloads/details.aspx?FamilyID=3861e56d-b5ed-4f7f-b2fd-5a53bc71dafc&displaylang=en e para obtê-la, vá em: http://support.microsoft.com/kb/948779

    Por favor nos retorne informando se tudo deu certo.

    []´s

    Amorim
    Carlos Amorim Junior
    • Marcado como Resposta Elzira domingo, 1 de março de 2009 22:10
    quarta-feira, 11 de fevereiro de 2009 12:54
  • Obrigada Olavo. Refizemos a instalação, acertamos as permissões e conseguimos avançar um pouco. O único problema que ainda persiste, é que só consigo me logar diretamente do servidor do CRM. Seguirei as orientações do Carlos Amorin, em relação ao Microsoft Dynamics CRM IFD Tool. 

    Elzira
    • Marcado como Resposta Elzira domingo, 1 de março de 2009 22:12
    quarta-feira, 11 de fevereiro de 2009 17:45
  •  Elzira,

    sei que parece um pouco óbvio, mas já desbloqueou seu firewall ? se instalou com "criar site" a porta padrão é 5555 portanto: http://seuservidor:5555/

    • Marcado como Resposta Elzira domingo, 1 de março de 2009 22:13
    quinta-feira, 19 de fevereiro de 2009 01:06
  • Agradeço a todos. Depois de muita briga, conseguimos fazer funcionar ... O documento IFD ajudou bastante.
    • Marcado como Resposta Elzira domingo, 1 de março de 2009 22:12
    domingo, 1 de março de 2009 22:10