none
Como limpar célula e manter a fórmula no VBA RRS feed

  • Discussão Geral

  • Estou com dificuldades ao limpar a célula em VBA ele apaga também a fórmula, queria ver com vocês se tem como ou algum código que impeça de fazer isso, estou fazendo os seguintes comando:

    Public Sub Cancelar()
    Call EfeitoMenuOpcao
    For a = 0 To 49
    shtCadastro.Range("Cad_" & a) = ""
    Next

    End Sub

    quinta-feira, 27 de dezembro de 2018 10:42

Todas as Respostas

  • Olá!

    Não é possível o que deseja de forma direta, nem faz sentido. O que é possível, e recomendado, é que sua fórmula retorne "vazio" para determinada condição: por exemplo, se uma dada célula estiver vazia, o resultado da fórmula é "". Daí basta que você apague esta célula escolhida.

    Exemplo:

    =SE(A1=""; ""; A1+B1)

    Compreendeu?


    Filipe Magno

    terça-feira, 1 de janeiro de 2019 23:41