none
Arquivo XML de Configuração RRS feed

  • Pergunta

  • Tenho diversos pacotes e estou utilizando arquivos XML que contêm as strings de conexão com os bancos de dados.

    Durante o processo de desenvolvimento, os pacotes reconhecem as alterações feitas nesses arquivos.

    Entretanto, quando executo esses pacotes a partir de um job no SSMS, parece que eles não utilizam os valores que estão nos arquivos de configuração. Alterei um dos arquivos XML, colocando um IP inválido, e o pacote não retornou o erro de conexão esperado.

    Fiz o deploy dos pacotes importando-os um a um através do SSMS, conectando-me ao servidor do Integration Services.

    Como devo proceder para que, na hora da execução dos pacotes, estes leiam os arquivos de configuração?

    Grato,

    Benedito.


    Benedito R. Almeida Filho - BI

    terça-feira, 15 de abril de 2014 20:38

Respostas

  • Benedito, certifique-se que o arquivo xml no servidor de produção está no mesmo caminho do servidor de desenvolvimento. Se o pacote não encontrar o xml de configuração ele vai assumir as configurações default das conexões/variáveis no seu pacote dtsx.

    Abs.


    Eduardo Gomes - http://www.h1solucoes.com.br - Twitter: @edugp_sp

    quarta-feira, 16 de abril de 2014 14:51

Todas as Respostas

  • Benedito, certifique-se que o arquivo xml no servidor de produção está no mesmo caminho do servidor de desenvolvimento. Se o pacote não encontrar o xml de configuração ele vai assumir as configurações default das conexões/variáveis no seu pacote dtsx.

    Abs.


    Eduardo Gomes - http://www.h1solucoes.com.br - Twitter: @edugp_sp

    quarta-feira, 16 de abril de 2014 14:51
  • Bom dia, Eduardo

    Grato pela sua resposta. Os arquivos em questão ficam em um diretório virtual que eu criei a partir de uma pasta na minha máquina: I:\PROJETO\LOG - PROJETO - SMEDW - DATAMART\XMLCONFIG. Fiz a mesma coisa no servidor onde os pacotes são executados.

    Será que o SQL Server consegue achar esta pasta? Vou fazer alguns teste e posto o resultado mais tarde.

    Benedito.


    Benedito R. Almeida Filho - BI

    quarta-feira, 23 de abril de 2014 11:58
  • Eduardo,

    Acredito que o problema seja o caminho dos arquivos (Drive I:\). Assim que eu puder, farei a alteração da pasta para o drive local e testarei os pacotes no servidor novamente.

    Grato,

    Benedito.


    Benedito R. Almeida Filho - BI

    quarta-feira, 23 de abril de 2014 17:26
  • Eduardo,

    Simplifiquei ao máximo o caminho e o nome dos arquivos XML (removi espaços em branco e coloquei a pasta no diretório raiz). Consegui fazer com que o pacote executando no servidor apontasse erro de conexão com a base de dados como eu esperava.

    Fico muito grato pela sua ajuda.

    Benedito.


    Benedito R. Almeida Filho - BI

    quarta-feira, 23 de abril de 2014 19:59