none
Erro - Plano de execução RRS feed

  • Pergunta

  • Boa tarde pessoal.

    Estou tendo alguns problemas ao executar um plano de execução. Sempre está apresentando o erro abaixo, isso independe da query ou tabelas envolvidas, sempre apresenta o erro.

    Já procurei em diversos lugares e sites e não encontrei uma resposta. Já verifiquei com os DBA's da onde trabalho mas até o presente momento não "souberam" me responder.

     

    An error occurred while executing batch. Error message is: Error processing execution plan results. The error message is:

    The type initializer for 'Microsoft.SqlServer.Management.SqlMgmt.ShowPlan.XmlPlanNodeBuilder' threw an exception.

    Não foi possível encontrar o módulo especificado.

     

    Obrigado, desde já.

     

    []'s

    Wellington

     

    terça-feira, 21 de agosto de 2007 20:00

Todas as Respostas

  • esse problema parece estar no managment studio e nao so servidor sql, vc. pode passar qual a versao do seu sql server ? .

     

    ja rodou a mesma rotina em outra maquina que tenha o managment studio

     

    Abs;

     

    quarta-feira, 22 de agosto de 2007 10:10
  • Olá Marcelo.

    Inicialmente agradeço pela rapidez.

     

    Vamos lá ... minhas configurações:

    minha máquina: XP(SP2), SQL 2005 (SP2)

    Servidor DB: SQL 2005 SP1

    Servidor: Win Server (Enterprise Edition) 2003 (SP1)

     

    Já verifiquei o plano em outra máquina e aparece o mesmo erro, por isso que achei que era algum componente ou configuração no proprio sv SQL faltando ou errado.

     

    Ao executar a query que passou aparece uma msg (gigantesca de todo o banco) em xml, só não postei porque, acredite em mim, é grande mesmo.

     

    Obrigado.

    Wellington

    quarta-feira, 22 de agosto de 2007 18:23
  • Wellington,

     

    Eu estava enfrentando este problema no meu notebook utilizando um máquina virtual, com o Windows Server 2003 e SQL Server 2005 SP1, fiz a atualização para o SP2 e o problema foi solucionado.

     

    quarta-feira, 22 de agosto de 2007 19:16
  • Pessoal.

    Depois de "insistências" com os DBA's daqui, me informaram que tem que conceder permissão para o meu usuário.

    Achei estranho pois sou owner do banco pertencente ao sysadmin.

     

    Mas funcionou!

     

    Obrigado!

    quarta-feira, 22 de agosto de 2007 20:45
  •  

    Olá Wellington,

     

    Que bom que resolveu seu problema. E, muito obrigado por dar o retorno, isso é muito importante para compartilhar soluções com todos que aqui participam.

     

     

     

    Abraço

    quinta-feira, 23 de agosto de 2007 03:51
  •  

    permissao, e realmente vivendo e aprendendo. mais qual permissao eles deram para seu usuario ?, vc. ja era sysadmin :

     

     

    Abs;

    quinta-feira, 23 de agosto de 2007 10:35
  • Bom dia Marcelo.

    Então, só informaram que foi aplicado um comando para o meu usuário aplicar o plano de execução ... por isso achei estranho, sou sysadmin e preciso de "permissão" para executar um explan ?

     

    Essa não entendi.

     

    Obrigado

     

    []'s

    Wellington

     

    quinta-feira, 23 de agosto de 2007 12:27
  • Wellington,

     

    Um comando, mas qual comando é este, eles não informaram?

    sexta-feira, 24 de agosto de 2007 10:55
  • Olha Junior, não sei.

    Eu perguntei o que foi feito, até mesmo para uma futura eventualidade ou compartilhar o conhecimento também com as pessoas ... mas só informaram isso, que foi um comando e tal ... estranho ...  !

     

    []'s

     

    sexta-feira, 24 de agosto de 2007 14:33