none
Problema com ASP.NET MVC 4 RRS feed

  • Pergunta

  • Estou recebendo este erro ao iniciar um projeto utilizando ASP.NET MVC 4 E Visual Studio 2012. Encontrei algumas soluções no Google que não funcionaram e o problema persiste. Alguém já passou por isso?

    Não foi possível carregar arquivo ou assembly 'System.ServiceModel, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' ou uma de suas dependências. O módulo deveria conter um manifesto de assembly.

    sexta-feira, 23 de agosto de 2013 00:42

Respostas

Todas as Respostas

  • Acho que você precisa registrar novamente o .NET Framework 4 com IIS. Tente o seguinte:

    Abra o prompt de comando como administrador, em seguida, navegue até a pasta. NET (% windir% \ Microsoft.NET \ Framework \ v4.0.30319). Em seguida, execute o seguinte comando:

    aspnet_regiis-iru
    sexta-feira, 23 de agosto de 2013 12:16
  • Bom, já fiz isso antes..... tem a baixo a lista do que já fiz.
    Nada abaixo funcionou de fato.
    Obrigado.

    Registrar o ASP.NET novamente (todas as versões).
    aspnet_regiis-iru
    Remover todos os Frameworks e instalar novamente (pela versão web e pela standalone)

    Reinstalar e Reparar o Visual Studio 2012

    Mandar compilar para x64 e x86 (meu pc é x64)

    Verificar se o serviço do Framework foi iniciado (e foi...)

    Registrar a versão 4 no IIS (e foi registrada)

    Criar a aplicação no Visual Studio 2010
    sexta-feira, 23 de agosto de 2013 12:27
  • Retirar todos os Frameworks e limpar o registro resolveu meu problema. De qualquer forma obrigado.
    sexta-feira, 23 de agosto de 2013 13:49