none
Erro ToolkitScriptManager RRS feed

  • Pergunta

  • Pessoal, Estou precisando da ajuda de vocês mais uma vez.

    Tenho uma site de teste que estou começando a fazer. nele existe uma pagina especifica que contem um controle Ajax, quando tento carregar esta pagina esta me dando um erro. 

    Por favor se alguém conseguir me ajudar ficarei muito grato.

    Caso queira visualizar o erro o site é: www.lavajatodocesar.com.br/configuracao.aspx

    Já subi todas as bibliotecas ajax para pasta Bin. Também já alterei o nivel de confiança do site para Full e nada.


    segunda-feira, 20 de outubro de 2014 22:13

Respostas

  • Boa noite Leandro,

    Experimente alterar a o valor da propriedade Level para Full. Essa propriedade faz parte da tag TRUST (código encontrado no arquivo web.config), conforme código abaixo.

    <configuration> 
      <system.web> 
        <trust level="Full" /> 
      </system.web> 
    </configuration> 

    Quando usa AjaxControlToolkit é recomendável deixar com o valor Full.

    Abs.

    Dicas de programação em .net, C# e SQL - http://smcode.com.br/blog.aspx


    segunda-feira, 20 de outubro de 2014 22:52

Todas as Respostas

  • Boa noite Leandro,

    Experimente alterar a o valor da propriedade Level para Full. Essa propriedade faz parte da tag TRUST (código encontrado no arquivo web.config), conforme código abaixo.

    <configuration> 
      <system.web> 
        <trust level="Full" /> 
      </system.web> 
    </configuration> 

    Quando usa AjaxControlToolkit é recomendável deixar com o valor Full.

    Abs.

    Dicas de programação em .net, C# e SQL - http://smcode.com.br/blog.aspx


    segunda-feira, 20 de outubro de 2014 22:52
  • Using AjaxControlToolkit version 7.0725, I encounter this issue also. Currently the only way I'm able to get around it is by setting the trust level to High or Full in the web.config.
    <configuration>
      <system.web>
          <trust level="High"/>
      </system.web>
    </configuration>
    If you have access to the machine.config, then you can add requirePermission="false" to the definition for the httpHandlers section. This is unfortunately not an option for many individuals though.
    <configuration>
        <configSections>
            <sectionGroup name="system.web" type="System.Web.Configuration.SystemWebSectionGroup, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a">
                <section name="httpHandlers" type="System.Web.Configuration.HttpHandlersSection, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" requirePermission="false" />
            </sectionGroup>
        </configSections>
    </configuration>

    https://ajaxcontroltoolkit.codeplex.com/workitem/26970

    • Sugerido como Resposta Deric Ferreira terça-feira, 21 de outubro de 2014 20:02
    terça-feira, 21 de outubro de 2014 20:02