none
Problemas com Visual Studio 2010 após atualização EF4.1 RRS feed

  • Pergunta

  • Boa noite,

    Estava utilizando perfeitamente o VS 2010 Professional com o Entity Framework 4.0. Após fazer a atualização para o Entity Framework 4.1 os arquivos .edmx não abrem mais no Designer (somente em visualização XML) e ao executar o projeto aparece o erro:

    "Could not load file or assembly 'System.Data.Entity, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies. O sistema não pode encontrar o arquivo especificado."

    O que fazer para tudo voltar ao normal? Já tentei até reinstalar tudo.

    Agradeço desde já qualquer ajuda

    André

    quarta-feira, 27 de julho de 2011 02:30

Todas as Respostas

  • André, você ja reparou a instalação da .Net Framework 4.0 ? Como você já disse que reinstalou o Visual Studio, já tentou em fazer uma restauração do sistema, voltando para o momento de antes de você instalar o Entity Framework 4.1 ? http://windows.microsoft.com/pt-BR/windows7/products/features/system-restore
    Olavo Oliveira Neto
    http://olavooneto.wordpress.com
    Se for útil marque como resposta e faça um Developer feliz :)
    quarta-feira, 27 de julho de 2011 12:24
  • Valeu Olavo, mas não adiantou. Eu reparei o .NET Framework 4.0 e já havia tentado restaurar o sistema para o momento anterior à instalação do EF4.1 mas não resolveu.

    Não sei se pode ajudar mas todos os EntityDataSource indicam o mesmo erro acima descrito.

    Além disso quando eu tento adicionar um ADO.NET Entity Data Model, não consigo e recebo a mensagem:

    "Method not found: 'Boolean Microsoft.Data.Tools.Diagnostics.Tracer.AssertTraceEvent(Boolean, System.Diagnostics.TraceEventType, Microsoft.Data.Tools.Diagnostics.TraceId, System.String)"

    Estou "sem pai nem mãe", afinal todos os estão projetos parados e não consigo dar sequencia.

    Obrigado.

    André Tella

     

    quarta-feira, 27 de julho de 2011 14:43