locked
Problema com LinkButton na propriedade IsEnabled (Visual studio 2010, 4.0) - VB .NET RRS feed

  • Pergunta

  • Oi, pessoal.

    Estou com um problema que está me tirando do sério.

    Tenho uma gridview que possui um linkbutton em uma das colunas. Essa grid é habilitada e carregada em duas situações distintas.

    Em uma situação esse linkbutton consegue carregar o link normalmente, mas em outra, não. Aparece o nome do link,mas quando passamos o mouse só muda a cor, sem aparecer o link propriamente dito, nada.

    Quando fui verificar percebi que, na situação em que o linkbutton não carrega o link, a propriedade "IsEnabled" está como false. Lembrando que não é a propriedade "Enable" (que é editável pelo código e está setado como "true" nas duas situações).

    Gostaria de saber se alguém pode me ajudar, porque não estou conseguindo entender porque está "IsEnabled: false" pra um, e pro outro "IsEnabled: true", e se posso forçar pra os dois ficarem "true".

    Obrigada!


    quinta-feira, 24 de setembro de 2015 16:32

Respostas

  • Oi, pessoal.

    Estou com um problema que está me tirando do sério.

    Tenho uma gridview que possui um linkbutton em uma das colunas. Essa grid é habilitada e carregada em duas situações distintas.

    Em uma situação esse linkbutton consegue carregar o link normalmente, mas em outra, não. Aparece o nome do link,mas quando passamos o mouse só muda a cor, sem aparecer o link propriamente dito, nada.

    Quando fui verificar percebi que, na situação em que o linkbutton não carrega o link, a propriedade "IsEnabled" está como false. Lembrando que não é a propriedade "Enable" (que é editável pelo código e está setado como "true" nas duas situações).

    Gostaria de saber se alguém pode me ajudar, porque não estou conseguindo entender porque está "IsEnabled: false" pra um, e pro outro "IsEnabled: true", e se posso forçar pra os dois ficarem "true".

    Obrigada!


    Você pode colar seu código do aspx aqui?
    E o seu código que proporciona os dois tipos de carregamento?

    Fulvio Cezar Canducci Dias

    poxa, os códigos são gigantes... como faço?

    tente colocar no pastebin.com acredito que fica fácil lá e aqui você disponibiliza o links


    Fulvio Cezar Canducci Dias

    • Marcado como Resposta Marcos SJ segunda-feira, 28 de setembro de 2015 11:43
    quinta-feira, 24 de setembro de 2015 20:40

Todas as Respostas

  • Oi, pessoal.

    Estou com um problema que está me tirando do sério.

    Tenho uma gridview que possui um linkbutton em uma das colunas. Essa grid é habilitada e carregada em duas situações distintas.

    Em uma situação esse linkbutton consegue carregar o link normalmente, mas em outra, não. Aparece o nome do link,mas quando passamos o mouse só muda a cor, sem aparecer o link propriamente dito, nada.

    Quando fui verificar percebi que, na situação em que o linkbutton não carrega o link, a propriedade "IsEnabled" está como false. Lembrando que não é a propriedade "Enable" (que é editável pelo código e está setado como "true" nas duas situações).

    Gostaria de saber se alguém pode me ajudar, porque não estou conseguindo entender porque está "IsEnabled: false" pra um, e pro outro "IsEnabled: true", e se posso forçar pra os dois ficarem "true".

    Obrigada!


    Você pode colar seu código do aspx aqui?
    E o seu código que proporciona os dois tipos de carregamento?

    Fulvio Cezar Canducci Dias

    quinta-feira, 24 de setembro de 2015 19:44
  • Oi, pessoal.

    Estou com um problema que está me tirando do sério.

    Tenho uma gridview que possui um linkbutton em uma das colunas. Essa grid é habilitada e carregada em duas situações distintas.

    Em uma situação esse linkbutton consegue carregar o link normalmente, mas em outra, não. Aparece o nome do link,mas quando passamos o mouse só muda a cor, sem aparecer o link propriamente dito, nada.

    Quando fui verificar percebi que, na situação em que o linkbutton não carrega o link, a propriedade "IsEnabled" está como false. Lembrando que não é a propriedade "Enable" (que é editável pelo código e está setado como "true" nas duas situações).

    Gostaria de saber se alguém pode me ajudar, porque não estou conseguindo entender porque está "IsEnabled: false" pra um, e pro outro "IsEnabled: true", e se posso forçar pra os dois ficarem "true".

    Obrigada!


    Você pode colar seu código do aspx aqui?
    E o seu código que proporciona os dois tipos de carregamento?

    Fulvio Cezar Canducci Dias

    poxa, os códigos são gigantes... como faço?

    quinta-feira, 24 de setembro de 2015 20:31
  • Oi, pessoal.

    Estou com um problema que está me tirando do sério.

    Tenho uma gridview que possui um linkbutton em uma das colunas. Essa grid é habilitada e carregada em duas situações distintas.

    Em uma situação esse linkbutton consegue carregar o link normalmente, mas em outra, não. Aparece o nome do link,mas quando passamos o mouse só muda a cor, sem aparecer o link propriamente dito, nada.

    Quando fui verificar percebi que, na situação em que o linkbutton não carrega o link, a propriedade "IsEnabled" está como false. Lembrando que não é a propriedade "Enable" (que é editável pelo código e está setado como "true" nas duas situações).

    Gostaria de saber se alguém pode me ajudar, porque não estou conseguindo entender porque está "IsEnabled: false" pra um, e pro outro "IsEnabled: true", e se posso forçar pra os dois ficarem "true".

    Obrigada!


    Você pode colar seu código do aspx aqui?
    E o seu código que proporciona os dois tipos de carregamento?

    Fulvio Cezar Canducci Dias

    poxa, os códigos são gigantes... como faço?

    tente colocar no pastebin.com acredito que fica fácil lá e aqui você disponibiliza o links


    Fulvio Cezar Canducci Dias

    • Marcado como Resposta Marcos SJ segunda-feira, 28 de setembro de 2015 11:43
    quinta-feira, 24 de setembro de 2015 20:40
  • Bom dia,

    Por falta de retorno do usuário, esta thread será encerrada.

    Caso seja necessário, por gentileza, abra uma thread nova.

    Atenciosamente


    Marcos Roberto de Souza Junior

    Esse conteúdo e fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    MSDN Community Support

    Por favor, lembre-se de Marcar como Resposta as respostas que resolveram o seu problema. Essa e uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    segunda-feira, 28 de setembro de 2015 11:43