none
ERRO NuGet (Incompatibilidade) RRS feed

  • Pergunta

  • Estou tentando abaixar uma versão de um desenvolvedor no NuGet e esse erro impossibilita a sua implementação:

    Não é possível resolver as dependências. 'NETStandard.Library 1.6.0' não é compatível com 'SampSharp.Core 0.8.0-alpha6 restrição: NETStandard.Library (>= 1.6.1)'.

    Se for para atualizar, como assim fazer? o projeto é em Console e requer o uso desta biblioteca para outras do desenvolvedor funcionar.

    sexta-feira, 18 de maio de 2018 00:41

Respostas

  • Olá, neste projeto é necessário instalar NETStandard.Library 1.6.0 ou superior, para isso acesse no visual studio o menu FERRAMENTAS (TOOLS) > NUGET PACKAGE MANAGER > MANAGE NUGET PACKAGE FOR SOLUTION. Então busque pelo NETStandard.Library 1.6.0 ou superior, instale na camada do projeto CONSOLE e tente novamente.

    Abs!


    Leandro de Agostini MCTS - Web Application, Framework 4

    • Marcado como Resposta KDST quinta-feira, 23 de agosto de 2018 21:10
    sexta-feira, 18 de maio de 2018 13:49

Todas as Respostas

  • Olá, neste projeto é necessário instalar NETStandard.Library 1.6.0 ou superior, para isso acesse no visual studio o menu FERRAMENTAS (TOOLS) > NUGET PACKAGE MANAGER > MANAGE NUGET PACKAGE FOR SOLUTION. Então busque pelo NETStandard.Library 1.6.0 ou superior, instale na camada do projeto CONSOLE e tente novamente.

    Abs!


    Leandro de Agostini MCTS - Web Application, Framework 4

    • Marcado como Resposta KDST quinta-feira, 23 de agosto de 2018 21:10
    sexta-feira, 18 de maio de 2018 13:49
  • Olá, neste projeto é necessário instalar NETStandard.Library 1.6.0 ou superior, para isso acesse no visual studio o menu FERRAMENTAS (TOOLS) > NUGET PACKAGE MANAGER > MANAGE NUGET PACKAGE FOR SOLUTION. Então busque pelo NETStandard.Library 1.6.0 ou superior, instale na camada do projeto CONSOLE e tente novamente.

    Abs!


    Leandro de Agostini MCTS - Web Application, Framework 4

    Eu fiz isso e resolveu Obrigado !

    Existe algum local para atualizar todos os pacotes para os mais recentes sem ter de abaixar os NuGet's necessários do projeto? até agora foram uns 5 e passou a funcionar, mas talvez, meu Visual Studio esteja precisando ser atualizado logo de uma vez.

    sexta-feira, 18 de maio de 2018 17:51