none
Erro ao acessar aplicação BI RRS feed

  • Pergunta

  • Boa noite Senhores.

    Estou com um problema, quando tento acesso ao BI de uma aplicação, o erro abaixo esta aparecendo.

    A conexão é feita em um SQL Server 2008 R2 em um servidor Windows server 2008 R2. Alguem pode me dar uma luz sobre o que esta ocorrendo, ja testei a conexão da maquina onde a aplicação esta rodando com o banco de dados, esta ok.

    Segue print da tela abaixo

    sábado, 8 de novembro de 2014 05:33

Respostas

  • Caro Caio, tente  conectar com o driver nativo do Sql-Server.

    Outra coisa que você pode testar eh pegar apenas o trecho de código que conecta ao Sql e validar se a conexão está acontecendo,  mesmo usanso o OleDB.

    Pelo erro enviado não é possível identificar se o problema está no grid ou na conexão,  se você conseguir conectar, possivelmente o erro está no render do DevExpress.

    Att,

    wcristoni

    • Marcado como Resposta Caio Queiroz quinta-feira, 13 de novembro de 2014 16:04
    sábado, 8 de novembro de 2014 07:06
  • Olá.

    Este erro ocorre muito comigo, quando o usuário não tem acesso ao banco.

    o que faço normalmente é checar o usuário, um usuário da maquina local, ou usuário do Active Directory. Abaixo segue um exemplo de minha conexão, utilizando um usuário da rede (A.D).

    <add name="OLAPTeste" connectionString="Provider=MSOLAP;Persist Security Info=False;Location=nomeinstancia\sql2008r2;Initial Catalog=nome_BI;Client Cache Size=25;Auto Synch Period=10000;User ID=dominio\nomeusuario;Password=123456;Data Source=nomeinstancia\sql2008r2;Cube Name=Movimentacao;"/>

    Existem outras acoes que realizo em algumas situações.

    abrir o Microsoft Sql Man Studio do sqlserver2008 -    Connect  - Analisys  e informe os dados do usuario e senha que vc está tentando usar na connection string.

    outras ações: 

    Colocar o usuario da rede no iis app pool que utilizo no site. Exemplo:   usuario  dominio\paulo no aplication pool de nome  "AppOlapteste".  e coloco o application pool para o site.

    Espero que te ajude.


    • Marcado como Resposta Caio Queiroz quinta-feira, 13 de novembro de 2014 16:03
    sábado, 8 de novembro de 2014 18:11

Todas as Respostas

  • Caro Caio, tente  conectar com o driver nativo do Sql-Server.

    Outra coisa que você pode testar eh pegar apenas o trecho de código que conecta ao Sql e validar se a conexão está acontecendo,  mesmo usanso o OleDB.

    Pelo erro enviado não é possível identificar se o problema está no grid ou na conexão,  se você conseguir conectar, possivelmente o erro está no render do DevExpress.

    Att,

    wcristoni

    • Marcado como Resposta Caio Queiroz quinta-feira, 13 de novembro de 2014 16:04
    sábado, 8 de novembro de 2014 07:06
  • Olá.

    Este erro ocorre muito comigo, quando o usuário não tem acesso ao banco.

    o que faço normalmente é checar o usuário, um usuário da maquina local, ou usuário do Active Directory. Abaixo segue um exemplo de minha conexão, utilizando um usuário da rede (A.D).

    <add name="OLAPTeste" connectionString="Provider=MSOLAP;Persist Security Info=False;Location=nomeinstancia\sql2008r2;Initial Catalog=nome_BI;Client Cache Size=25;Auto Synch Period=10000;User ID=dominio\nomeusuario;Password=123456;Data Source=nomeinstancia\sql2008r2;Cube Name=Movimentacao;"/>

    Existem outras acoes que realizo em algumas situações.

    abrir o Microsoft Sql Man Studio do sqlserver2008 -    Connect  - Analisys  e informe os dados do usuario e senha que vc está tentando usar na connection string.

    outras ações: 

    Colocar o usuario da rede no iis app pool que utilizo no site. Exemplo:   usuario  dominio\paulo no aplication pool de nome  "AppOlapteste".  e coloco o application pool para o site.

    Espero que te ajude.


    • Marcado como Resposta Caio Queiroz quinta-feira, 13 de novembro de 2014 16:03
    sábado, 8 de novembro de 2014 18:11
  • Verifiquei a connection String da maquina de aplicação e o usuario e senha descritos la estava errados. Apos alterado com os dados corretos o problema foi resolvido.

    Muito obrigado!

    quinta-feira, 13 de novembro de 2014 16:04