none
Problemas com WEB.CONFIG !!! RRS feed

  • Pergunta

  • Eai galera fmz ?

    Desenvolvi um site em ASPX framework4.5 na minha maquina roda tranquilo, mais quando coloco ele em produção ele aponta esse erro.(uso o uolHost).

    não consigo fazer rodar, alguém pode me ajudar ?

    aqui esta o código do web.config

    <?xml version="1.0" encoding="utf-8"?>
    <!--
      For more information on how to configure your ASP.NET application, please visit
      http://go.microsoft.com/fwlink/?LinkId=169433
      -->
    <configuration>
      <configSections>
        <!-- For more information on Entity Framework configuration, visit http://go.microsoft.com/fwlink/?LinkID=237468 -->
        <section name="entityFramework" type="System.Data.Entity.Internal.ConfigFile.EntityFrameworkSection, EntityFramework, Version=5.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="true" />
      </configSections>
      <connectionStrings>
        <add name="DefaultConnection" providerName="System.Data.SqlClient" connectionString="Data Source=(LocalDb)\v11.0;Initial Catalog=aspnet-WebApplicationAugusto-20130814120018;Integrated Security=SSPI;AttachDBFilename=|DataDirectory|\aspnet-WebApplicationAugusto-20130814120018.mdf" />
      </connectionStrings>
      <system.web>
        <globalization culture="pt-BR" />
        <compilation debug="true" targetFramework="4.5" />    
        <httpRuntime targetFramework="4.5" />
        <pages>
          <namespaces>
            <add namespace="System.Web.Optimization" />
          </namespaces>
          <controls>
            <add assembly="Microsoft.AspNet.Web.Optimization.WebForms" namespace="Microsoft.AspNet.Web.Optimization.WebForms" tagPrefix="webopt" />
          </controls>
        </pages>
        <authentication mode="Forms">
          <forms loginUrl="~/Account/Login.aspx" timeout="2880" />
        </authentication>
        <profile defaultProvider="DefaultProfileProvider">
          <providers>
            <add name="DefaultProfileProvider" type="System.Web.Providers.DefaultProfileProvider, System.Web.Providers, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" connectionStringName="DefaultConnection" applicationName="/" />
          </providers>
        </profile>
        <membership defaultProvider="DefaultMembershipProvider">
          <providers>
            <add name="DefaultMembershipProvider" type="System.Web.Providers.DefaultMembershipProvider, System.Web.Providers, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" connectionStringName="DefaultConnection" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="false" requiresUniqueEmail="false" maxInvalidPasswordAttempts="5" minRequiredPasswordLength="6" minRequiredNonalphanumericCharacters="0" passwordAttemptWindow="10" applicationName="/" />
          </providers>
        </membership>
        <roleManager defaultProvider="DefaultRoleProvider">
          <providers>
            <add name="DefaultRoleProvider" type="System.Web.Providers.DefaultRoleProvider, System.Web.Providers, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" connectionStringName="DefaultConnection" applicationName="/" />
          </providers>
        </roleManager>
        <sessionState mode="InProc" customProvider="DefaultSessionProvider">
          <providers>
            <add name="DefaultSessionProvider" type="System.Web.Providers.DefaultSessionStateProvider, System.Web.Providers, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" connectionStringName="DefaultConnection" />
          </providers>
        </sessionState>
      </system.web>
      <entityFramework>
        <defaultConnectionFactory type="System.Data.Entity.Infrastructure.LocalDbConnectionFactory, EntityFramework">
          <parameters>
            <parameter value="v11.0" />
          </parameters>
        </defaultConnectionFactory>
      </entityFramework>
    </configuration>
    

    agradeço a atenção desde já.

    quinta-feira, 22 de agosto de 2013 18:08

Respostas

  • Por padrão o ASP.NET mascara os erros exibindo uma página amigável de erro quando se acessa remotamente...

    Vá lá no Web.Config e habilite a seção CustomErros para exibir o erro ORIGINAL pra sabermos o que está acontencendo...

    Dentro da seção <system.web> coloque o código abaixo...

    <customErrors Mode="Off"/>

    OBS: De relance eu arriscaria dizer que seria a String de Conexão, você está passando corretamente os dados ?


    Leonardo Lourenço Silva
    MCT, MCSD, MCPD, MCTS, MCP, MTA
    netcoders.com.br
    leolosi.wordpress.com

    quinta-feira, 22 de agosto de 2013 18:17
  • Augusto.Xavier tudo blxx cara,

    Acredito que esse erro esta sendo causado pelo conflito do framework da sua aplicação com o do pool do IIS....... da uma olhada no IIS qual o application pool vc configurou a sua aplicação..... se o seu framework do  webconfig estiver 4.0 ou 4.5 no pool vc pode deixar a  v4.0 que a sua aplicação irá rodar sem problema algum... Aqui tem muitas informações para Especificar uma versão do .NET Framework para um pool de aplicativos  .....

    abraço !!!!!!!!!!!!!!!


    Diego Almeida Barreto System Analyst / Software Developer


    quinta-feira, 22 de agosto de 2013 18:50

Todas as Respostas

  • Por padrão o ASP.NET mascara os erros exibindo uma página amigável de erro quando se acessa remotamente...

    Vá lá no Web.Config e habilite a seção CustomErros para exibir o erro ORIGINAL pra sabermos o que está acontencendo...

    Dentro da seção <system.web> coloque o código abaixo...

    <customErrors Mode="Off"/>

    OBS: De relance eu arriscaria dizer que seria a String de Conexão, você está passando corretamente os dados ?


    Leonardo Lourenço Silva
    MCT, MCSD, MCPD, MCTS, MCP, MTA
    netcoders.com.br
    leolosi.wordpress.com

    quinta-feira, 22 de agosto de 2013 18:17
  • Depois q coloquei o

    <customErrors mode="Off" />

    ele deu esse erro

    quinta-feira, 22 de agosto de 2013 18:24
  • Esse ai é o erro ORIGINAL, seu plano da suporte ao ASP.NET 4.5 ?

    Faz um teste ae, vira de 4.5 para 4.0


    Leonardo Lourenço Silva
    MCT, MCSD, MCPD, MCTS, MCP, MTA
    netcoders.com.br
    leolosi.wordpress.com

    quinta-feira, 22 de agosto de 2013 18:28
  • Augusto.Xavier tudo blxx cara,

    Acredito que esse erro esta sendo causado pelo conflito do framework da sua aplicação com o do pool do IIS....... da uma olhada no IIS qual o application pool vc configurou a sua aplicação..... se o seu framework do  webconfig estiver 4.0 ou 4.5 no pool vc pode deixar a  v4.0 que a sua aplicação irá rodar sem problema algum... Aqui tem muitas informações para Especificar uma versão do .NET Framework para um pool de aplicativos  .....

    abraço !!!!!!!!!!!!!!!


    Diego Almeida Barreto System Analyst / Software Developer


    quinta-feira, 22 de agosto de 2013 18:50