none
Visual Studio 2005 - Reporting Services - Deserialization failed RRS feed

  • Pergunta

  • Olá,

    Dia desses abri um projeto do SSRS e ao entrar no Designer do relatório apareceu a seguinte mensagem de erro:

    "Deserialization failed: Could not load type 'Microsoft.VisualStudio.Shell.IOleMenuCommand' from assembly 'Microsoft.VisualStudio.Shell.Interop.8.0, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'. Line 2, position 2."

    Notei também que, ao acessar a opção "SEARCH" do "HELP" também aparecia a mesma mensagem. Já desinstalei e instalei a aplicação e o problema persiste.

    Alguém aí já passou por este problema ? Conseguiu uma solução ?

    Abraço a todos,


    Igor

    quinta-feira, 16 de julho de 2009 20:08

Respostas

  • Junior,

    Este problema aqui não é novidade, foi a segunda vez que aconteceu comigo. Sempre depois de uma atualização automática do Windows (Windows Update). Acredito que tenha alguma policy no AD com relação ao meu ID que esteja prejudicando a minha instalação, uma vez que, outros usuários não foram afetados pelo problema após a atualização do Windows.

    Abs,


    Igor
    • Marcado como Resposta Igor Nader quarta-feira, 5 de agosto de 2009 13:10
    quarta-feira, 5 de agosto de 2009 13:09

Todas as Respostas

  • Igor,

    Faz muito tempo que você instalou este Visual Studio?

    Já aplicou algum service pack?


    Pedro Antonio Galvão Junior - MVP - Windows Server System - SQL Server/Coordenador de Projetos/DBA
    segunda-feira, 20 de julho de 2009 12:25
  • Olá Júnior,

    Não faz muito tempo. Estou utilizando o Service Pack 2.

    Abs,


    Igor
    segunda-feira, 3 de agosto de 2009 19:45
  • Igor,

    Essa mensagem esta aparecendo somente para este projeto?


    Pedro Antonio Galvão Junior - MVP - Windows Server System - SQL Server/Coordenador de Projetos/DBA
    terça-feira, 4 de agosto de 2009 00:38
  • Junior,

    Não, qualquer projeto de Reporting (inclusive, já testei estes projetos em outra máquina com a aplicação instalada e tudo funciona perfeitamente). Ela aparece no momento em que abro uma consulta. Esta mensagem também aparece quando acesso o Help da aplicação, seja no Reporting, Analysis, etc...
    terça-feira, 4 de agosto de 2009 14:00
  • A solução menos traumática que encontrei foi a desinstalação por completo da aplicação e re-instalação. Feito isso, tudo voltou ao normal.

    Abs,


    Igor
    terça-feira, 4 de agosto de 2009 17:15
  • Igor,

    Obrigado pelo retorno, passei o dia procurando algumas informações e todas que encontrei destacam justamente a formatação como a solução, mas também pode observar que esse erro é causa devido a uma atualização do Visual Studio após aplicação do SP2.
    Pedro Antonio Galvão Junior - MVP - Windows Server System - SQL Server/Coordenador de Projetos/DBA
    quarta-feira, 5 de agosto de 2009 00:33
  • Junior,

    Este problema aqui não é novidade, foi a segunda vez que aconteceu comigo. Sempre depois de uma atualização automática do Windows (Windows Update). Acredito que tenha alguma policy no AD com relação ao meu ID que esteja prejudicando a minha instalação, uma vez que, outros usuários não foram afetados pelo problema após a atualização do Windows.

    Abs,


    Igor
    • Marcado como Resposta Igor Nader quarta-feira, 5 de agosto de 2009 13:10
    quarta-feira, 5 de agosto de 2009 13:09