locked
CONDICIONAL SE RRS feed

  • Pergunta

  • Boa tarde a todos!

     

    Pessoal, é o seguinte: preciso de uma formula condicional que FAÇA A SOMA de valores MAIORES QUE ZERO e QUE ESTEJA ENTRE 01/01/2008 E 31/01/2008.

    Abaixo planilha para podermos ilustrar melhor.

     

     

    A B C
    1 Fluxo de caixa ($) Data de liquidação do fluxo
    2 (+) para entradas e (-) para saídas
    3 90,00 05/01/2008
    4 90,00 02/01/2008
    5 (80,00) 02/02/2008
    6 (110,00) 02/03/2008
    7 100,00 02/01/2008
    8 30,00 02/01/2008

     

    Aguardo a ajuda de vocês.

    Muito Obrigado!

    terça-feira, 15 de julho de 2008 20:33

Respostas

  • Olá.

    Tomando-se por base sua planilha de exemplo, a fórmula abaixo representa uma das possíveis soluções:

    =SOMA((B3:B8 > 0)*(C3:C8 >= DATA(2008;1;1))*(C3:C8 <= DATA(2008;1;31))) SHIFT + CTRL + ENTER

    Não se esqueça de finalizar a digitação da fórmula acima pressionando SHIFT+CTRL+ENTER, pois esta é uma fórmula de matriz.

    Edição do post original:

    Olhando a fórmula postada pelo Adilson, abaixo, observei que a minha está errada. Segue a correção:

    Code Snippet

    =SOMA((B3:B8)*(B3:B8 > 0)*(C3:C8 >= DATA(2008;1;1))*(C3:C8 <= DATA(2008;1;31))) SHIFT + CTRL + ENTER

     

     

    Atenciosamente,

     

    terça-feira, 15 de julho de 2008 21:12
  • Outra sugestão:

    =SOMARPRODUTO((B3:B8)*(B3:B8>0)*(MÊS(C3:C8)=1))

    1º argumento: (B3:B8) representa o intervalo a ser somado

    2º argumento: (B3:B8>0) representa a condição de somar apenas números positivos

    3º argumento: (MÊS(C3:C8)=1) representa a condição das datas estarem dentro do mês 1.

    OBS: Caso seja necessário trabalhar com meses fechados, a sintaxe acima é mais curta. Porém no caso em que as datas inicial e final não correspondam exatamente ap início e término do mês, a sintaxe seria similar à apresentada pelo Otávio.

    =SOMARPRODUTO((B3:B8)*(B3:B8>0)*(C3:C8 >= DATA(2008;1;1))*(C3:C8 <= DATA(2008;1;31)))

     

     

    [ ]s

     

    quarta-feira, 16 de julho de 2008 10:15

Todas as Respostas

  • Olá.

    Tomando-se por base sua planilha de exemplo, a fórmula abaixo representa uma das possíveis soluções:

    =SOMA((B3:B8 > 0)*(C3:C8 >= DATA(2008;1;1))*(C3:C8 <= DATA(2008;1;31))) SHIFT + CTRL + ENTER

    Não se esqueça de finalizar a digitação da fórmula acima pressionando SHIFT+CTRL+ENTER, pois esta é uma fórmula de matriz.

    Edição do post original:

    Olhando a fórmula postada pelo Adilson, abaixo, observei que a minha está errada. Segue a correção:

    Code Snippet

    =SOMA((B3:B8)*(B3:B8 > 0)*(C3:C8 >= DATA(2008;1;1))*(C3:C8 <= DATA(2008;1;31))) SHIFT + CTRL + ENTER

     

     

    Atenciosamente,

     

    terça-feira, 15 de julho de 2008 21:12
  • Outra sugestão:

    =SOMARPRODUTO((B3:B8)*(B3:B8>0)*(MÊS(C3:C8)=1))

    1º argumento: (B3:B8) representa o intervalo a ser somado

    2º argumento: (B3:B8>0) representa a condição de somar apenas números positivos

    3º argumento: (MÊS(C3:C8)=1) representa a condição das datas estarem dentro do mês 1.

    OBS: Caso seja necessário trabalhar com meses fechados, a sintaxe acima é mais curta. Porém no caso em que as datas inicial e final não correspondam exatamente ap início e término do mês, a sintaxe seria similar à apresentada pelo Otávio.

    =SOMARPRODUTO((B3:B8)*(B3:B8>0)*(C3:C8 >= DATA(2008;1;1))*(C3:C8 <= DATA(2008;1;31)))

     

     

    [ ]s

     

    quarta-feira, 16 de julho de 2008 10:15
  • Valeu mesmo pessoal! Agora, td ok!!

     

    Abraços!

    sexta-feira, 18 de julho de 2008 11:38