none
Meu site so funciona quando eu publico ele pelo Visual Studio RRS feed

  • Pergunta

  • Caros amigos.
    estou com um problema, eh que eu estou desenvolvendo um site na plataforma .net... e meu problema eh o seguinte.
    eu quero publicar meu site em um outro computador,Apartir dos arquivos gerados pelo visual studio.
    Eu consigo ,executar o site quando eu clico em publish no visual studio ai, s eu for no browser e digtar http://localhost/meusite/default.aspx
    pega corretamente.

    ----
     s eu pegar os arquivos gerados pelo visual studio e copiar e colar em outro computador,e criar um diretorio apontando pra ele fazendo as configuracoes do iis normalmente,ele nao funciona!
    essa eh a maneira certa d s fazer??

    ou eu tenhu q pegar tds esses arquivos instalar o visual studio na maquina da pessoa e gerar um publish??
    que trabalho esse heim...

    Gostaria d resolver meu problema!
    agradeço..
    Att,
    Jairannnn   

    • Movido Rogerio Jerez quinta-feira, 29 de outubro de 2009 17:02 Movido para o Fórum Apropriado (De:Fórum MSDN)
    terça-feira, 14 de julho de 2009 17:22

Respostas

  • Finalmente companheiros... depois d ter feito uns backup no sistema vim ver q existia uma pasta q o VS tetva enviar pro wwwroot mas so que na mesma nao tinha ndh a dava esse failed..
    apaguei a pasta...
    e deu tudo certo..
    era uma pasta onde estava alguns scripts de uma porrada de componente!!
    .....
    agradeço ajuda a tds vcs!!!



    Quem menos anda voaa!!
    • Marcado como Resposta Jairan quinta-feira, 20 de agosto de 2009 19:37
    quinta-feira, 20 de agosto de 2009 19:36

Todas as Respostas

  • e sempre me da essa mensagem ...


    Server Application Unavailable

    The web application you are attempting to access on this web server is currently unavailable.  Please hit the "Refresh" button in your web browser to retry your request.

    Administrator Note: An error message detailing the cause of this specific request failure can be found in the application event log of the web server. Please review this log entry to discover what caused this error to occur

    ..

    agradeço a tds..
    Att,
    Jairannnn

    terça-feira, 14 de julho de 2009 17:47
  • Jairan,

    1° Vc pode publicar seu projeto usando o publish (conforme dito por vc) do VS em outra máquina, basta apenas compartilhar a pasta e passar o caminho no do diretorio no momento em que for publicar.

    2° Quanto a questao do erro, como esta a configuração da web application ?


    Abraço,

     


    Nelson Borges - http://nelsonborgesjr.spaces.live.com/blog/
    • Marcado como Resposta Jairan terça-feira, 18 de agosto de 2009 13:06
    • Não Marcado como Resposta Jairan quinta-feira, 20 de agosto de 2009 19:31
    quarta-feira, 15 de julho de 2009 00:53
  • jairan,


    Podem ser vários problemas:

    Voçê utiliza alguma ligação a um servidor de base de dados no seu site?
    O IIS está bem configurado para correr o site? {ex: configação da porta, localização da pasta com o website no IIS, se o IIS tem o site a correr }


    Podes colocar aqui os detalhes do log que se encontram no "application event log", como te aconselha o próprio erro?



    Cumprimentos

    Bruno Pires - www.blastersystems.com/blog
    • Marcado como Resposta Jairan terça-feira, 18 de agosto de 2009 13:06
    • Não Marcado como Resposta Jairan quinta-feira, 20 de agosto de 2009 19:32
    quarta-feira, 15 de julho de 2009 16:22
  • Eh como eu analisei podem ser varios problemas
    assim como vcs disseram..
    eu depois d mto tempo ... desinstalando e instalando o framework..
    ai depois d um tempo pegou nao se qual o motivo..
    mas td bem..
    agora so tow comum problema so na hora dar o publish no visual studio..
    eu clico ... crio o diretorio e td certinho...
    ai ele me informa publish failed..
    ..
    agradeço a ajuda de vcs!!!
    abraçossss
    Att Jairan ...        Quem menos nda Voaa...
    segunda-feira, 3 de agosto de 2009 16:42
  • Você poderia postar o OUTPUT que o Publish está gerando ?

    Estou com uma pequena disconfiança que o problema agora passou a ser algum arquivo "em uso" ou "somente leitura".
    Para testar, verifique se alguem está utilizando a aplicação, se possível, pare a aplicação no IIS e realize o Publish novamente.
    Se der erro, verifique se tem algum arquivo como "Somente Leitura".

    Se for uma publicação local ( no proprio PC ) verifique se tem algum arquivo "em uso" ( pare o WebDev se possível ) e faça o publish.
    Se der erro, verifique se tem algum arquivo como "Somente Leitura".

    Qualquer duvida, posta aqui para que possamos te ajudar.
    Rafael F. P.
    MTS em Aplicações WEB c/ .NET 2.0
    Se alguém consegui te ajudar, poderia marcar como "Respondido" ? Grato. :)
    • Sugerido como Resposta Rafael F P segunda-feira, 17 de agosto de 2009 12:52
    • Marcado como Resposta Jairan terça-feira, 18 de agosto de 2009 13:06
    • Não Marcado como Resposta Jairan quinta-feira, 20 de agosto de 2009 19:33
    quarta-feira, 12 de agosto de 2009 14:51
  • Finalmente companheiros... depois d ter feito uns backup no sistema vim ver q existia uma pasta q o VS tetva enviar pro wwwroot mas so que na mesma nao tinha ndh a dava esse failed..
    apaguei a pasta...
    e deu tudo certo..
    era uma pasta onde estava alguns scripts de uma porrada de componente!!
    .....
    agradeço ajuda a tds vcs!!!



    Quem menos anda voaa!!
    • Marcado como Resposta Jairan quinta-feira, 20 de agosto de 2009 19:37
    quinta-feira, 20 de agosto de 2009 19:36