none
SMTP Port 587 Outbound Connection RRS feed

  • Pergunta

  • Hello everyone!

    Hope this question is in the right place!!!

    Here is my issue...:

    I have one simple Azure Virtual Machine Server, with Windows 2012 R2 installed. I have installed on application specific for sending e-mail notifications from within this server... This same application was installed into one internal server at my office and here i am able to send e-mail notifications using one simple SMTP server (smtp.infofisc.com.br port 587)

    I am able to telnet this smtp server form any other server, but from within this Azure server i am not able to open conection with this SMTP server... i have asked some friend to try to telnet this address but none of then were able to open conectino to this smtp address...

    Can you guys please help me understand if it is possible? If i need to do something inside Azure control panel o something to open port 587 for outbound connection?

    Thank you!


    Marque como util se esta resposta o ajudou!!!

    quarta-feira, 11 de março de 2015 20:07

Respostas

  • Olá Francisco,

    Este forum é em português.

    Fiz o teste a partir de algumas maquinas na Internet e também de um site na Internet que faz verificações de portas abertas (Online Port Check - http://openport.net/) e o status é que a porta TCP 587 está realmente fechada. Veja screenshot:

    Creio que necessitas verificar seu Firewall está configurado correto para a abertura do porta TCP 587.

    Att

    Daniel Mauser
    LATAM Azure Support

    quarta-feira, 11 de março de 2015 23:43
  • Olá Matheus!

    De fato não consegui conexão como o smtp.infofisc.com.br na porta 587 de nenhum dos servidores Azure dos quais tenho acesso, solicitei também a amigos e nenhum deles conseguiu... O curioso neste caso é que todos eles conseguiram conexão utilizando servidores internos ou mesmo suas próprias estações de trabalho ou notebooks...

    Verificando com o provedor de e-mails de meu cliente, kinghost.com.br, descobri que para envio de e-mails de IP`s de fora do pais era necessário habilitar esta opção via painel de controle da conta infofisc.com.br. ao habilitar esta opção eu deveria utilizar o endereço smtpi.infofisc.com.br, e com isso eu pude configurar o envio de e-mail em minha aplicação neste servidor Azure. Com isso o telnet passou a se conectar utilizando a mesma porta 587.

    Surgem então outras duvidas sendo a primeira a mais curiosa,... Se esta VM no Azure está localizada em um Datacenter no Brasil, acredito eu, por qual razão o e-mail estaria sendo enviado de um endereço do exterior?(Por pura curiosidade ainda estou pesquisando esta questão de IP`s das minhas VM`s no Azure)....

    Em resumo, você estava certo em relação a porta 587 estar fechada, mas ela é fechada apenas para IP`s de fora do Brasil!

    A solução foi liberar este acesso junto ao provedor!

    Obrigado pela ajuda Matheus!


    Marque como util se esta resposta o ajudou!!!

    segunda-feira, 16 de março de 2015 11:46

Todas as Respostas

  • Olá Francisco,

    Este forum é em português.

    Fiz o teste a partir de algumas maquinas na Internet e também de um site na Internet que faz verificações de portas abertas (Online Port Check - http://openport.net/) e o status é que a porta TCP 587 está realmente fechada. Veja screenshot:

    Creio que necessitas verificar seu Firewall está configurado correto para a abertura do porta TCP 587.

    Att

    Daniel Mauser
    LATAM Azure Support

    quarta-feira, 11 de março de 2015 23:43
  • Olá Daniel!

    Verifiquei no provedor de e-mail em questão e notei que a funcão de "SMTP Internacional" não estava habilitada. Ao habilitar esta função foi possivel me conectar a este SMTP via Telnet utilizando o endereço smtpi.telnet.com.br...

    Outro detalhe é o fato de eu já ter este mesmo SMTP configurado e funcionando em outros servidores, todos no Brasil...

    De minha rede em Campinas o resultado do telnet é este, mesmo com o site de teste de porta acusando-a como fechada:

    Vou continuar a testar e ver o que consigo descobrir a mais!

    Por enquanto obrigado por sua atenção!


    Marque como util se esta resposta o ajudou!!!

    quinta-feira, 12 de março de 2015 11:54
  • Bom dia Francisco,

    Quando tiver um retorno se possível postar o que foi testado e como foi para ajudar a aumentar o volume de solução para o Azure.

    Obrigado


    Matheus Leopardi Mello Canelada Campos

    Esse conteúdo e fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    TechNet Community Support

    Por favor, lembre-se de Marcar como Resposta as respostas que resolveram o seu problema. Essa e uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    sexta-feira, 13 de março de 2015 14:30
  • Olá Matheus!

    De fato não consegui conexão como o smtp.infofisc.com.br na porta 587 de nenhum dos servidores Azure dos quais tenho acesso, solicitei também a amigos e nenhum deles conseguiu... O curioso neste caso é que todos eles conseguiram conexão utilizando servidores internos ou mesmo suas próprias estações de trabalho ou notebooks...

    Verificando com o provedor de e-mails de meu cliente, kinghost.com.br, descobri que para envio de e-mails de IP`s de fora do pais era necessário habilitar esta opção via painel de controle da conta infofisc.com.br. ao habilitar esta opção eu deveria utilizar o endereço smtpi.infofisc.com.br, e com isso eu pude configurar o envio de e-mail em minha aplicação neste servidor Azure. Com isso o telnet passou a se conectar utilizando a mesma porta 587.

    Surgem então outras duvidas sendo a primeira a mais curiosa,... Se esta VM no Azure está localizada em um Datacenter no Brasil, acredito eu, por qual razão o e-mail estaria sendo enviado de um endereço do exterior?(Por pura curiosidade ainda estou pesquisando esta questão de IP`s das minhas VM`s no Azure)....

    Em resumo, você estava certo em relação a porta 587 estar fechada, mas ela é fechada apenas para IP`s de fora do Brasil!

    A solução foi liberar este acesso junto ao provedor!

    Obrigado pela ajuda Matheus!


    Marque como util se esta resposta o ajudou!!!

    segunda-feira, 16 de março de 2015 11:46