none
Erro ERR_CONNECTION_RESET RRS feed

  • Pergunta

  • Acabei de restaurar meu Windows, e agora estou tendo problema para rodar minhas aplicações ASP.NET Core com HTTPS.

    Como o certificado instalado por padrão não funcionou, excluí e gerei outro. Mas mesmo assim, continua não funcionando.

    Comandos utilizados até o momento:

    dotnet dev-certs https --clean

    dotnet dev-certs https --trust

    Alguém tem alguma ideia do que pode estar acontecendo?

    Já fiz todos os procedimentos descritos em: https://github.com/dotnet/aspnetcore/issues/16892.

    Quando eu rodo a aplicação em HTTP funciona. Mas quando rodo em HTTPS, ao invés de aparecer o cadeado, aparece o I (i), informando que a conexão não é segura. Apesar de estar rodando na porta do SSL.

    terça-feira, 22 de setembro de 2020 13:17

Todas as Respostas

  • Ola Daniel,

    Onde voce esta rodando a aplicação? IIS ou IIS Express?

    Você já checou o binding da aplicação para ver se a configuração para https ainda esta lá? 
    terça-feira, 22 de setembro de 2020 15:31
    Moderador
  • Estou executando no IIE Express.
    terça-feira, 22 de setembro de 2020 20:04
  • Bom dia Daniel,

    Da uma olhada no binding da sua aplicação. Verifica se o binding ainda esta lá e se o SSL cert esta selecionado, como mostra abaixo.

    quarta-feira, 23 de setembro de 2020 13:13
    Moderador
  • Os screenshots não foi com a mensagem. Aqui esta um link de uma página que mostra como instalar e configurar o cert de novo no IIS

    https://www.ssls.com/knowledgebase/how-to-install-an-ssl-certificate-on-iis-10/

    quarta-feira, 23 de setembro de 2020 13:18
    Moderador
  • Boa tarde Mauricio,

    Certificado no IIS Express: https://1drv.ms/u/s!ApWE7PbCwp351TPHZbPY8m91yMRG

    Erro na execução do projeto: https://1drv.ms/u/s!ApWE7PbCwp351TXH9Q_IAtO4Eh9n

    quarta-feira, 23 de setembro de 2020 18:53
  • Que tipo de certificado e esse? CA? self signed? 

    Você verificou se o cert esta selecionado no binding? 

    Que diretório o seu certificado esta instalado no Windows? 

    Capaz que você tenha que instalar o certificado no Windows de novo

    quarta-feira, 23 de setembro de 2020 20:33
    Moderador
  • Bom dia, Mauricio.

    O certificado é self signed, está no binding e está na minha pasta de usuário (..\users\daniel.chagas).

    O problema está no meu Antivírus. Assim que eu removi, parou de dar problema.

    Tem alguma configuração que está causando esse problema. Assim que eu conseguir resolver, volto com a solução.

    Obrigado pela ajuda!


    sexta-feira, 25 de setembro de 2020 12:01
  • Ainda não consegui resolver o problema. Mas posso afirmar que o problema está no Kaspersky.

    Se eu fechar o antivírus, tudo funciona muito bem.

    Assim que eu resolver o problema, volto com a solução.


    sábado, 3 de outubro de 2020 01:18
  • Problema resolvido!

    Aparentemente é um problema com o Kaspersky 2021.

    O suporte voltou com a versão 2020 e mexeu em umas chaves de registro. Tudo funcionando...

    terça-feira, 6 de outubro de 2020 15:34