none
Erro Crystal Reports For VS.NET 2005 RRS feed

  • Pergunta

  •  

    Pessoal estou tendo problemas em um relatório feito no Crystal Reports For VS.NET 2005, estou visualizando o mesmo com o próprio visualizador do Crystal (WinForms/VB.NET).
    Quando envio para a impressora ou tento exportar recebo a mensagem abaixo:

    Error in File C:\.......}.rpt:
    The request could not submitted for background processing.

    Algéum já passou por isso?
    É um relatório relativamente grande, cerca de 100 folhas também tem imagem no mesmo. Tenho vários outros relatórios mas só neste apresenta o erro.
    Consultei na página da própria Business Objects, até fala sobre este erro mas de forma muito genérica manda verificar se tem  service pack ou hot fix, mas não tem menhuma atualização para o CR For .NET 2005.

    Agradeço qualquer ajuda... obrigado.

     

    quinta-feira, 1 de junho de 2006 17:53

Respostas

  • Edson,

     

       Já fez a instalação do SP1 do Crystal Reports .NET 2005 na sua máquina?

     

      Onde baixar:

      https://www.sdn.sap.com/irj/sdn/businessobjects-downloads

     

      Caso seja exibido uma tela para selecionar o certificação digital, clique no botão ok.

      Na tela de pesquisa faça o seguinte filtro:

     

      Software Product = Crystal Reports

      Product Version (optional)  = .NET

      e clique no botão search

     

      Faça o download do Crystal Reports for .NET 2005 - SP 1

      Instalar na máquina de desenvolvimento (Faça a instalação com o Visual Studio 2005 fechado!)

     

      Em todas as máquinas onde a aplicação vai ser executada, também será necessário instalar o "runtime" do Crystal Reports (Seja para uma aplicação ASP.NET ou Window Forms)

     

      Faça o download do CR for .NET Framework 2.0 Redistributable Package (x86) para (OS 32 Bits)

      Faça o download do CR for .NET Framework 2.0 Redistributable Package (x64) para (OS 64 Bits)

      

      Dentro do arquivo .ZIP existe um arquivo .DOC que contém o passo a passo de como gerar o SETUP para distribuir corretamente o "runtime" do Crystal Reports.

     

    Agora, se mesmo assim o erro continuar: the request could not be submitted for background processing

     

    No Sistema Operacional onde está dando erro, entre com o usuário Administrador e rode a aplicação (Eu dei uma olhada em outros fórum e este erro está relacionado a falta de permissão de escrita no diretório temp.)

     

     

    segunda-feira, 14 de julho de 2008 13:34

Todas as Respostas

  • Edson ,

    No asp Alliance tem varios exemplos de uso do Crystal com Visual Studio 2005 , chega e da uma olhada :

    http://aspalliance.com/crystal/

    Agora na pagina da businessobjects de suporte tem  a resolução para seu problema.

    http://support.businessobjects.com/library/kbase/articles/c2017617.asp

     

    sexta-feira, 2 de junho de 2006 14:44
  • Já havia visitado esta página na Business Objects, mas como já havia comentado, diz que a solução seria fazer a atualização com um Service Pack ou Hot Fix, mas para a versão CR.NET 2005 não existe menum dos dois.

    Mesmo assim obrigado Daniel.

     

    sexta-feira, 2 de junho de 2006 16:48
  • Edson, estou com o mesmo problema que vc. A propósito conseguiu resolver?

     

    Obrigado.

     

    segunda-feira, 14 de julho de 2008 12:49
  • Edson,

     

       Já fez a instalação do SP1 do Crystal Reports .NET 2005 na sua máquina?

     

      Onde baixar:

      https://www.sdn.sap.com/irj/sdn/businessobjects-downloads

     

      Caso seja exibido uma tela para selecionar o certificação digital, clique no botão ok.

      Na tela de pesquisa faça o seguinte filtro:

     

      Software Product = Crystal Reports

      Product Version (optional)  = .NET

      e clique no botão search

     

      Faça o download do Crystal Reports for .NET 2005 - SP 1

      Instalar na máquina de desenvolvimento (Faça a instalação com o Visual Studio 2005 fechado!)

     

      Em todas as máquinas onde a aplicação vai ser executada, também será necessário instalar o "runtime" do Crystal Reports (Seja para uma aplicação ASP.NET ou Window Forms)

     

      Faça o download do CR for .NET Framework 2.0 Redistributable Package (x86) para (OS 32 Bits)

      Faça o download do CR for .NET Framework 2.0 Redistributable Package (x64) para (OS 64 Bits)

      

      Dentro do arquivo .ZIP existe um arquivo .DOC que contém o passo a passo de como gerar o SETUP para distribuir corretamente o "runtime" do Crystal Reports.

     

    Agora, se mesmo assim o erro continuar: the request could not be submitted for background processing

     

    No Sistema Operacional onde está dando erro, entre com o usuário Administrador e rode a aplicação (Eu dei uma olhada em outros fórum e este erro está relacionado a falta de permissão de escrita no diretório temp.)

     

     

    segunda-feira, 14 de julho de 2008 13:34
  •  

    Pessoal, este problema já resolvi conforme o Laercio comentou. Instalando o CR for .Net 2005 SP1, inclusive nos clientes.

    Grato!

    segunda-feira, 14 de julho de 2008 13:42
  • Blz Edson! Além disso, corrigi o texto do meu post para fazer a pesquisa corretamente no site da BO pq eles mudaram tudo e está muito ruim fazer o filtro para achar o SP1 e Runtime do Crystal Reports para .NET.

     

    Agora está correto (Até que a BO faça novamente uma alteração no site de busca)!

     

    Valeu!

     

     

    segunda-feira, 14 de julho de 2008 13:52
  • Ruim é apelido. O BO realmente facilou feio.

     

    Desde já obrigado pela sugestão. Agora com o LINK certo vou testar novamente.

    segunda-feira, 14 de julho de 2008 14:13
  • Fala Laercio. Rapaz, instalei tudo certinho aqui na minha máquina porém continua o erro.

     

    Tenho o VS2008 tb instalado. Será que é por causa disso?

     

     

     

    segunda-feira, 14 de julho de 2008 14:44
  • Maxwel,

     

    Tenho o VS2008 tb instalado. Será que é por causa disso?

     

    Vc está rodando o .NET 2005 correto? então acho que não deveria dar erro, apesar que no VS2008 também existe o Crystal Reports que está "recheado" de bug.

     

    Na boa, como sugestão, eu faria o seguinte:

     

    Desinstalar tudo (.NET 2008 e .NET 2005).

    Efetuar um boot

    Instalar novamente o .NET 2005

    Aplicar o SP1 do Visual Studio 2005

    Efetuar um boot

    Aplicar o SP1 do Crystal Reports .NET 2005

     

    Não por falta de compatibilidade entre o .NET 2005 e .NET 2008 (que funcionam juntos sem problemas), agora o crystal reports já não posso dizer o mesmo.

     

    Além disso, o Edson também estava com o mesmo problema e resolvou aplicando o mesmo procedimento.

    http://forums.microsoft.com/msdn-br/ShowPost.aspx?PostID=3613031&SiteID=21

     

     

     

     

     

     

     

    segunda-feira, 14 de julho de 2008 17:06
  •  

    Estranho cara. Pois no cliente tb instalei o CRRedist2008_x86.msi e o crvs05sp1.exe. Certo? E o problema continua.

     

    Na máquina do desenvolvimento ainda vou fazer esse teste de desinstalar e instalar novamente, mas o que me diz a respeito do cliente?

     

    Notei que no VS 2005 tem o CRRedist2005_x86.msi e não CRRedist2008_x86.msi, logo instalei os dois, na respectava ordem e depois instalei o crvs05sp1.

     

    Seria isso que eu deveria fazer no cliente?

     

    Vc comentou em tópicos atrás que tinha um arquivo .doc explicando como publicar, porém quando eu descompactei não tinha nenhum .doc, apenas o crvs05sp1.exe.

     

     

    Outra coisa, já reparou que no site do BO (no novo local de download de Hot Fix e SP) que na GRID que é carregada ele tem a opção de navegação porém quando clicamos para a próxima página ele dá pau. Percebeu isso? Testei com o IE 6 SP2 e o Firefox, não sei se no IE 7 dá isso tb. Na moral, temos que fazer uma ação, e-mail em grupo, uma espécie de abaixo assinado para melhorarem essa seção do BO. É uma vergonha.

     

     

    Obrigado.
    terça-feira, 15 de julho de 2008 13:30
  • Olá Laercio e Edson,
    bom, a coisa tá ficando feia, já desistalei tudo e instalei na ordem sugerida e não resolveu.

    Notei que meu projeto está fazendo referência as DLLs:

    CrystalDecisions.CrystalReports.Engine.dll
    CrystalDecisions.Shared.dll

    que estão localizadas em C:\Arquivos de programas\Arquivos comuns\Business Objects\2.7\Managed

    E AMBAS na VERSÃO 10.2.52001.1823

    Já está inslado o SP do VS2005 e do CR.

    Estou usando Winform com VS2005, NO WINDOWS xp.

    VCs PODERIAM CONFIRMAR SE A VERSÃO DAS DLLS CITADAS ACIMA É A MESMA????


    Obrigado,
    terça-feira, 15 de julho de 2008 21:27
  • Maxwel,

     

    Eu tenho as mesmas versões das DLLs, além disso, não precisa instalar o Service Pack do Crystal .NET 2005 e do .NET 2008 no cliente ou na sua máquina de desenvolvimento (ternha apenas o SP1 do Crystal Reports para .NET 2005 e os Runtimes do Crystal Reports .NET 2005 e mais nada).

     

    Vamos  centralização a solução do problema neste link (fica mais fácil para identificar o problema):

    http://forums.microsoft.com/MSDN-BR/ShowPost.aspx?PostID=3622271&SiteID=21

     

     

     

     

     

     

    quarta-feira, 16 de julho de 2008 11:08
  •  

    Ingresar a la siguiente web:

     

    https://websmp130.sap-ag.de/sap(bD1lcyZjPTAwMQ==)/bc/bsp/spn/bobj_download/main.htm

     

     

    Bajar e instalar el siguiente archivo:

    Crystal Reports for .NET 2005 - SP 1

    terça-feira, 12 de agosto de 2008 22:00
  • Estou com o mesmo problema!

    vou atualizar AGORA!!

    Pra ver se é isso!!!!!! 

    terça-feira, 5 de fevereiro de 2013 20:36