none
Efetuar Cálculo à partir do 2º dado inputado RRS feed

  • Pergunta

  • Boa Tarde pessoal.

    Estou com uma dúvida que pode ser absolutamente simples, porém não encontrei uma forma de resolver pelo Google da vida.

    O que acontece é o seguinte: Preciso realizar um cálculo de porcentagem.

    Exemplo:

    Tenho um valor de resultados do 1º Trimestre de uma empresa, tenho o resultado do 2º Trimestre de uma empresa e na 3ª coluna, tenho o valor da evolução em porcentagem, se foi positivo ou negativa, comparando os trimestres.

    Porém, ao inserir o primeiro dado na coluna 1º Trimestre, eu gostaria que o resultado do cálculo com o 2º Trimestre, só aparecesse na 3ª coluna quando eu colocasse o dado do 2º Trimestre, que é o que não está acontecendo... Exemplo: coloco R$ 23,00 na primeira coluna, e na terceira já aparece 100%...a sintaxe que estou usando na 3ª coluna esta (=SE(ÉERROS(H5/G5-1);"";H5/G5-1))... como esperar o dado da segunda coluna para então sim mostrar o resultado na 3ª coluna?... se ficou um pouco confuso de entender, eu explico novamente.

    Desde já, obrigado pela força

    quinta-feira, 31 de março de 2016 20:03

Respostas

  • Bruno,

    você pode usar um SE para definir se existe valor ou não na H5

    =SE(H5="";0;SE(ÉERROS(H5/G5-1);"";H5/G5-1))

    Att,


    Antero Marques

    __________________________________________________________________________

    Se a resposta for útil, marque como útil, se respondeu totalmente sua dúvida, marque como resposta.

    O Fórum MSDN é utilizado também como base de conhecimento, então é responsabilidade de todos mantê-lo organizado e funcional.


    • Editado Antero Marques quinta-feira, 31 de março de 2016 20:49
    • Marcado como Resposta Bruno Breda sexta-feira, 1 de abril de 2016 10:41
    quinta-feira, 31 de março de 2016 20:49

Todas as Respostas

  • Bruno,

    você pode usar um SE para definir se existe valor ou não na H5

    =SE(H5="";0;SE(ÉERROS(H5/G5-1);"";H5/G5-1))

    Att,


    Antero Marques

    __________________________________________________________________________

    Se a resposta for útil, marque como útil, se respondeu totalmente sua dúvida, marque como resposta.

    O Fórum MSDN é utilizado também como base de conhecimento, então é responsabilidade de todos mantê-lo organizado e funcional.


    • Editado Antero Marques quinta-feira, 31 de março de 2016 20:49
    • Marcado como Resposta Bruno Breda sexta-feira, 1 de abril de 2016 10:41
    quinta-feira, 31 de março de 2016 20:49
  • Bom dia Antero.

    Obrigado pela dica.

    Tentei com o uso do "SE" também, mas estava colocando a condição do "H5=verdadeiro". E estava apresentando erro.

    Sua fórmula me ajudou, porém, mesmo assim na terceira coluna aparecia o valor de "0", que no caso substituí pela fórmula: =SE(H5="";"";SE(ÉERROS(H5/G5-1);"";H5/G5-1)) - e deu certo

    Abraços.


    • Editado Bruno Breda sexta-feira, 1 de abril de 2016 10:50 Concordância Verbal
    sexta-feira, 1 de abril de 2016 10:41