locked
Erro Linq RRS feed

  • Pergunta

  • Boa tarde!

    Fiz a migração do meu projeto pelo fato de um arquivo estar corrompido. Após isto, estou apanhando destes erros.

    Já tentei usar todas as referências possíveis e imagináveis, mas nada. :(

    Obrigado


    Leonardo D'Amato


    quarta-feira, 14 de outubro de 2015 15:09

Respostas

  • Oi Daniel!!

    Então cara, parece que eu consegui resolver aqui, as versões do EntityFramework de cada projeto eram diferentes, então eu desinstalei ele de todos os projetos e reinstalei, e parece que deu certo.

    Porém, na hora de rodas o aplicativo, ele não abre mais:


    Leonardo D'Amato

    • Marcado como Resposta Marcos SJ quinta-feira, 15 de outubro de 2015 13:33
    quinta-feira, 15 de outubro de 2015 13:02

Todas as Respostas

  • Bom dia Leonardo N. D'Amato,

    Que tipo de migração você fez?

    Poderia dar mais detalhes?


    Marcos Roberto de Souza Junior

    Esse conteúdo e fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    MSDN Community Support

    Por favor, lembre-se de Marcar como Resposta as respostas que resolveram o seu problema. Essa e uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    quinta-feira, 15 de outubro de 2015 11:33
  • Olá,

     você adicionou a referência :

    using System.Linq;
     Qual framework está utilizando ?

    quinta-feira, 15 de outubro de 2015 11:37
  • Bom dia,

    Então, atualizaram para o EF 6.1.3 aqui, e desde então, está dando esse erro.


    Leonardo D'Amato

    quinta-feira, 15 de outubro de 2015 11:57
  • Olá Leonardo,

     poste uma dessas classes que gera o erro com suas respectivas referências os famosos "using".

    quinta-feira, 15 de outubro de 2015 12:15
  • Oi Daniel!!

    Então cara, parece que eu consegui resolver aqui, as versões do EntityFramework de cada projeto eram diferentes, então eu desinstalei ele de todos os projetos e reinstalei, e parece que deu certo.

    Porém, na hora de rodas o aplicativo, ele não abre mais:


    Leonardo D'Amato

    • Marcado como Resposta Marcos SJ quinta-feira, 15 de outubro de 2015 13:33
    quinta-feira, 15 de outubro de 2015 13:02
  • Olá Leonardo,

     isso seria outro erro, sugiro abrir outro thread !

     Mas verifique se existe uma connection string chamada ctx no seu arquivo appConfig e se todas referencias do EF está la.

    quinta-feira, 15 de outubro de 2015 19:47