none
CRM 2011 - Perfil de Segurança de Campo RRS feed

  • Pergunta

  • Boa tarde.

    Gostaria de saber se alguém consegue me ajudar com um problema.

    Criei vários campos customizados e habilitei Segurança de Campo em todos eles.

    Porém, as regras não se aplicam a nenhum usuário. Nenhum usuário do teste era administrador do sistema, e seus perfis eram com poucos privilégios, mesmo assim não respeitou nenhuma regra de campos que eu tinha criado previamente.

    Como exemplo usei um campo e não dei permissão ao usuário fazer nenhuma alteração e nem leitura, porém ele pode ler e gravar normalmente.

    Fiz um teste em minha VM e o mesmo procedimento funcionou corretamente, fiquei com a impressão que seja algum problema com ambiente, ou algo do tipo.

    Alhguém já passou por este problema ?

    Estou no CRM 2011 on-promisse.

    Obrigado.

    Diego


    segunda-feira, 4 de junho de 2012 16:10

Respostas

  • O problema parece não ter sido de parametrização/configuração

    Testei a mesma Solution em outro ambiente e funcionou.
    Tenho a impressão que algo ocorreu com o AD e a vinculação com os usuários na Organização.

    A solução foi instalar e implantar novamente o CRM, e a mesma solution funcionou perfeitamente no ambiente novo, com os mesmos requisitos e configurações.

    Fica a dica caso o mesmo aconteça com alguém aqui.

    Obrigado a todos pela ajuda.

    Diego

    • Marcado como Resposta Diego Molezine segunda-feira, 25 de junho de 2012 05:52
    segunda-feira, 25 de junho de 2012 05:52

Todas as Respostas

  • Diego,

    Perguntas óbvias, mas não custa tentar...

    - Você publicou a solução?

    - As regras e campos estavam presentes na exportação de solução?

    - Os perfis de acesso foram adicionados na solução? Pois nativamente eles não são adicionados, temos que abrir a solução e adicionar

    Att,


    Tiago Michelini Cardoso MVP - MCC - MCTS
    https://tiagomcardoso.wordpress.com/

    terça-feira, 5 de junho de 2012 21:54
    Moderador
  • Além das perguntas obvias do Tiago, verifique outro detalhe:

    Os direitos de acesso/perfis são cumulativos, portanto, assegure-se que nenhum perfil com maior abrangência esteja sobrepondo algum perfil mais fraco associado ao usuário.


    Virtual Group - Soluções Inteligentes www.virtualgroup.com.br

    sexta-feira, 8 de junho de 2012 01:46
  • Veja se este link te ajuda com os passos http://inogic.blogspot.com.br/2010/10/field-level-security-in-crm-2011.html

    Atenciosamente,
    Rodrigo Hentz - MCP.MCPS.MCNPS.MCTS.MBSS.MBSP.MCITP
    Profile
    Blog

    domingo, 10 de junho de 2012 14:25
    Moderador
  • Diego,

    Alguma novidade?

    Att,


    Tiago Michelini Cardoso MVP - MCC - MCTS
    https://tiagomcardoso.wordpress.com/

    segunda-feira, 18 de junho de 2012 12:09
    Moderador
  • O problema parece não ter sido de parametrização/configuração

    Testei a mesma Solution em outro ambiente e funcionou.
    Tenho a impressão que algo ocorreu com o AD e a vinculação com os usuários na Organização.

    A solução foi instalar e implantar novamente o CRM, e a mesma solution funcionou perfeitamente no ambiente novo, com os mesmos requisitos e configurações.

    Fica a dica caso o mesmo aconteça com alguém aqui.

    Obrigado a todos pela ajuda.

    Diego

    • Marcado como Resposta Diego Molezine segunda-feira, 25 de junho de 2012 05:52
    segunda-feira, 25 de junho de 2012 05:52